Bug 66567 - auctex package not properly installed (AUCDIR not set)
Summary: auctex package not properly installed (AUCDIR not set)
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: xemacs   
(Show other bugs)
Version: 7.2
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-06-12 11:12 UTC by diego.santacruz
Modified: 2007-04-18 16:43 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-17 07:39:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description diego.santacruz 2002-06-12 11:12:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020606

Description of problem:
The package auctex is not properly installed: the @AUCDIR string in tex-site.el
is not replaced by the proper installation directory path.

Version-Release number of selected component (if applicable):
21.1.14-23.7.2

How reproducible:
Always

Steps to Reproduce:
1. start XEmacs
2. load a latex doc
3. start auctex mode
	

Actual Results:  auctex's style files are not loaded since they cannot be found.
As a consequence auctex cannot complete macros and environments that are loaded
through \usepackage

Expected Results:  auctex's builtin style files should be loaded

Additional info:

The installation procedure should replace @AUCDIR in
/usr/lib/xemacs/xemacs-packages/lisp/auctex/tex-site.el by
/usr/lib/xemacs/xemacs-packages/etc/auctex (I guess).

Comment 1 Trond Eivind Glomsrxd 2002-06-12 20:09:54 UTC
To quote the elisp file in question (from the xemacs in Rawhide, which is what I
have installed) - this is how it's distributed from upstream:

;;; XEmacs change:
;; Commented out because the XEmacs packages do not use the AUC TeX
;; install procedure
;; (defvar TeX-lisp-directory "@AUCDIR"
;;   "*The directory where the AUC TeX lisp files are located.")


Comment 2 diego.santacruz 2002-06-13 07:10:30 UTC
Well even if it comes as that from upstream it is wrong!
Once the installation dir is known, @AUCDIR should be replaced by the real
directory path, in this case /usr/lib/xemacs/xemacs-packages/etc/auctex/.

Failing to do that, auctex does not recognize the environments defined in
packages imported with \usepackage{} in latex files, for example
\usepackage{amsmath}.

Please fix this in the RPM, or forward it to XEmacs upstream, but it ought to be
fixed. Since everything is distributed in one RPM, the user should not be
required to start fiddling with configuration files so that auctex works as it
should.

Comment 3 Trond Eivind Glomsrxd 2002-06-14 22:52:06 UTC
It should not be necesarry with XEmacs' configuration system, that's why they're
explicitly not setting it. Do you have an example file demonstrating the problem?

Comment 4 diego.santacruz 2002-06-17 07:39:23 UTC
Load auctex in a standard XEmacs installation and then consult the value of the
TeX-lisp-directory variable. It does not have the path, it just has the @AUCDIR
value. Then start a document like

\documentclass[a4paper,10pt]{article}
\usepackage{amsmath}
\usepackage{amsfonts}
\usepackage{amssymb}

Then if you do C-c C-e to insert a new environment, auctex will not list the
amsmath environments because TeX-lisp-directory does not contain the path where
amsmath.el is to be found. If you set TeX-lisp-directory to
/usr/lib/xemacs/xemacs-packages/etc/auctex/ then auctex does list the amsmath
environments.

This has apparently been fixed in recent XEmacs versions, see
http://cvs.xemacs.org/viewcvs.cgi/XEmacs/packages/xemacs-packages/auctex/tex-site.el,
revisions 1.3 to 1.6. This fix should appear as from version 1.30 of the auctex
package, released 2002-03-25 (don't know if it made it to the sumos or not).


Comment 5 Trond Eivind Glomsrxd 2002-06-17 19:41:49 UTC
The version in the sumo tarballs is 1.31, which is why it worked fine here...
closing as rawhide


Note You need to log in before you can comment on or make changes to this bug.