Bug 665964 - /etc/host.conf is obsolete
/etc/host.conf is obsolete
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: setup (Show other bugs)
rawhide
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-28 00:53 EST by ritz
Modified: 2011-04-21 03:15 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 665962
Environment:
Last Closed: 2011-01-03 06:51:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ritz 2010-12-28 00:53:11 EST
+++ This bug was initially created as a clone of Bug #665962 +++

Description of problem:
/etc/host.conf gives no indication that it has been deprecated. Adding comment to the file would be helpful for new users.

Version-Release number of selected component (if applicable):
setup

How reproducible:
always

Steps to Reproduce:
1. cat /etc/host.conf
  
Actual results:
no indication it is deprecated

Expected results:
Should be documented in man pages, /etc/host.conf file itself

Additional info:
reference - https://bugzilla.redhat.com/show_bug.cgi?id=144687
Comment 1 Ondrej Vasik 2011-01-03 06:51:58 EST
Well - I tend to say this is NOTABUG - as /etc/host.conf is still in use in glibc (recently we added multi on option to default /etc/host.conf to allow localhost alias even on IPv6 machine). Anyway - man page documenting host.conf file is coming from man-pages package and glibc resolve/res_hconf.c still uses /etc/host.conf - so I think https://bugzilla.redhat.com/show_bug.cgi?id=144687 is no longer correct.

Feel free to explain why it should be considered deprecated - and discuss this with glibc maintainer - Andreas Schwab - first. Closing NOTABUG - file still in use (and res_hconf.c uses it by default - with no use of nsswitch.conf).
Comment 2 Siddhesh Poyarekar 2011-04-21 03:15:19 EDT
host.conf is in fact used by glibc is not completely obsolete. But there is no reason for it to be installed by default with the line:

order bind,hosts

since the order keyword is precisely the one that does not do anything anymore. Keeping this intact in a default installation gives the wrong impression that the line is in use.

At the minimum, we could remove this 'order' line and install a blank file in case removal of the file creates confusion about the file not being in use at all.

Can we reopen this bz?

Note You need to log in before you can comment on or make changes to this bug.