Bug 666081 - asterisk runs as root instead of asterisk user due to rc script bug
Summary: asterisk runs as root instead of asterisk user due to rc script bug
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: asterisk
Version: rawhide
Hardware: All
OS: Unspecified
low
high
Target Milestone: ---
Assignee: Jeffrey C. Ollie
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 718336 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-28 20:40 UTC by Jason Spangler
Modified: 2011-10-11 02:05 UTC (History)
4 users (show)

Fixed In Version: asterisk-1.8.6.0-4.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-03 18:09:46 UTC
Type: ---


Attachments (Terms of Use)

Description Jason Spangler 2010-12-28 20:40:42 UTC
Description of problem:
asterisk runs as root instead of asterisk user due to rc script bug

Version-Release number of selected component (if applicable):
asterisk-1.8.0-3.fc15.i686

How reproducible:
Just install and run asterisk

Steps to Reproduce:
1. Install asterisk
2. Run asterisk
3. ps waxu | grep asterisk
  
Actual results:
asterisk is running as root

Expected results:
asterisk is running as user asterisk

Additional info:

To fix, change AST_ARGS to ASTARGS in the following lines of /etc/rc.d/init.d/asterisk:

  if [ $AST_USER ] ; then
    ASTARGS="$AST_ARGS -U $AST_USER"
  fi
  if [ $AST_GROUP ] ; then
    ASTARGS="$AST_ARGS -G $AST_GROUP"
  fi

Comment 1 Jeffrey C. Ollie 2011-09-20 13:54:44 UTC
*** Bug 718336 has been marked as a duplicate of this bug. ***

Comment 2 Fedora Update System 2011-09-20 20:21:08 UTC
asterisk-1.8.6.0-4.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/asterisk-1.8.6.0-4.fc16

Comment 3 Fedora Update System 2011-09-20 20:25:19 UTC
asterisk-1.8.6.0-4.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/asterisk-1.8.6.0-4.fc15

Comment 4 Fedora Update System 2011-09-20 20:26:13 UTC
asterisk-1.8.6.0-4.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/asterisk-1.8.6.0-4.el6

Comment 5 Fedora Update System 2011-09-20 20:51:09 UTC
asterisk-1.6.2.20-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/asterisk-1.6.2.20-1.fc14

Comment 6 Fedora Update System 2011-09-21 22:15:11 UTC
Package asterisk-1.8.6.0-4.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing asterisk-1.8.6.0-4.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/asterisk-1.8.6.0-4.fc16
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2011-10-03 18:09:11 UTC
asterisk-1.8.6.0-4.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2011-10-03 23:56:54 UTC
asterisk-1.8.6.0-4.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2011-10-03 23:57:57 UTC
asterisk-1.6.2.20-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2011-10-11 02:05:12 UTC
asterisk-1.8.6.0-4.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.