Bug 666094 - RFE: Update to 2.6 release series
Summary: RFE: Update to 2.6 release series
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: puppet
Version: 14
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Jeroen van Meeuwen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 659367 (view as bug list)
Depends On: 718390
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-28 23:37 UTC by Jonathan Underwood
Modified: 2011-09-27 23:01 UTC (History)
8 users (show)

Fixed In Version: puppet-2.6.6-1.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-26 17:56:08 UTC


Attachments (Terms of Use)

Description Jonathan Underwood 2010-12-28 23:37:45 UTC
Description of problem:
The 2.6.x release series was released in July, and seems reasonably stable. Any chance of pushing this to F-14 and rawhide? Also, what are your thoughts on pushing this for EPEL 5? In my limited testing, compatibility seems good, though I have to admit I switched to using 2.6 pretty soon after it was released and didn't use 0.25.5 very much.

Comment 1 Todd Zullinger 2010-12-29 02:51:23 UTC
We've held off pushing this to any Fedora releases until we're ready to push it to EPEL as well, since many many folks run puppet masters on EL and clients on Fedora.

The biggest thing we need is testing from 0.25.x setups to 2.6.x and confirmation that the update is indeed compatible.  I have provided 2.6.x builds for Feodra and EPEL at http://tmz.fedorapeople.org/repo/puppet/ since 2.6.x was in beta and have solicited feedback on the puppet lists and IRC.  The relatively little feedback I've received has been mostly positive, but not sufficient to make me comfortable to push 2.6.x into epel-testing quite yet.  I do think 2.6.4 is pretty close, but more testing from folks who have successfully (and cleanly) upgraded from 0.25.5 to 2.6.4 would be very helpful.

Sadly, it seems many folks just consume the packages and leave us hanging as maintainers.  I fear that when we do eventually push 2.6.x into epel-testing and fedora we will find folks upgrading and complaining of minor incompatibilities that should have been caught by folks testing the various release candidates during the past 6 months. :(

Comment 2 Orion Poplawski 2011-03-14 21:39:46 UTC
Any more progress on this?  I'm just getting started with puppet and I'd like to start with up to date versions.  Not much help with the upgrade I'm afraid though.

Comment 3 Todd Zullinger 2011-03-14 21:51:43 UTC
Yes.  I'll be pushing 2.6.6 into fedora and epel testing repositories in the next day or two, assuming no show-stopper bugs are found¹.

¹ I planned this with 2.6.5 a few weeks ago and the day after it was released
some ugly regressions were found, necessetating 2.6.6.  Hence my desire to let
the newst code simmer for a few days. :)

Comment 4 Todd Zullinger 2011-03-18 18:58:42 UTC
*** Bug 659367 has been marked as a duplicate of this bug. ***

Comment 5 Fedora Update System 2011-03-18 20:01:10 UTC
puppet-2.6.6-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/puppet-2.6.6-1.fc14

Comment 6 Fedora Update System 2011-03-18 20:01:43 UTC
puppet-2.6.6-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/puppet-2.6.6-1.el5

Comment 7 Fedora Update System 2011-03-18 20:02:11 UTC
puppet-2.6.6-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/puppet-2.6.6-1.fc15

Comment 8 Fedora Update System 2011-03-18 20:02:37 UTC
puppet-2.6.6-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/puppet-2.6.6-1.fc13

Comment 9 Fedora Update System 2011-03-18 20:03:03 UTC
puppet-2.6.6-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/puppet-2.6.6-1.el6

Comment 10 Duncan Innes 2011-09-12 10:30:02 UTC
Any chance of a package update on this?  It's been 6 months since the 2.6.6 release of puppet.

The 2.6 release had been updated to 2.6.9 by June, since when work has clearly concentrated on the 2.7 release.

The 2.7 release itself has now been updated to 2.7.3.

Puppet will be an integral part of the Katello project.  It would be nice to be able to run one of the more recent Puppet releases.

It's just a thought.

Comment 11 Todd Zullinger 2011-09-12 13:41:58 UTC
The 2.6.6 packages have been in fedora and epel testing repos for a long time now.  The last thing blocking us now is SELinux policy on EL-6.  I've tried to find out when this will be pushed in RHEL but have had no luck.  Anyone with contacts inside Red Hat that could give some insight would be great.

I'm soon going to push this to stable and just not on epel-announce that anyone running with SELinux in enforcing mode should get updated slinux-policy packages from Dan Walsh's people.redhat.com repo or set it to permissive until RHEL updates that package.

See https://bugzilla.redhat.com/show_bug.cgi?id=718390

Comment 12 Todd Zullinger 2011-09-12 13:55:48 UTC
As far as upstream and 2.7, there are a number of changes that have the potential to cause users troubles.  An upgrade will require determining whether these changes are reasonable to expect in a stable update.

A few that come to mind:

* Variable scoping.  Puppet 2.7 issues deprecation warnings for dynamic variable and resource defaults lookup.  More details are at http://docs.puppetlabs.com/guides/scope_and_puppet.html .

* The hasstatus parameter in the service resource type now defaults to true.  In general, this is a good thing, since nearly all initscripts in EL/EPEL have a status option.  But, this change could break existing manifests.

* The --parseonly option to puppet has been removed and replaced with puppet parser validate.  The latter has slightly different semantics and output, I've been told.  I spoke with Michael Stahnke from Puppetlabs and it may be worth filing this as a bug upstream.  It's possible that they'll restore --parseonly to retain compatibility.  One of the reasons it was dropped is that it sometimes reported success when it should have failed, so folks relying on it now are suffering from implementation bugs.

Comment 13 Jonathan Underwood 2011-09-12 14:40:22 UTC
Todd - thanks as ever for your work on this. One thought though - if you're intending to push a 2.6 series update to stable, wouldn't it be worth considering pushing 2.6.9 which fixes a number of the 2.6.6 bugs? I realize 2.6.6 has had a lot of testing over the past few months and so one could argue that's a safer bet for stable, but in my experience, the 2.6.9 release was a drop in replacement for 2.6.6.

Comment 14 Todd Zullinger 2011-09-12 15:16:51 UTC
At this point, I don't want to negate the testing that 2.6.6 has received and introduce new bugs with 2.6.9.  I have 2.6.9 packages in my fedorapeople repo and as soon as 2.6.6 is moved to stable, 2.6.9 can go to testing, where it shouldn't required too long to be proven.

Comment 15 Jonathan Underwood 2011-09-12 16:04:14 UTC
Fair enough.

Comment 16 Fedora Update System 2011-09-26 17:55:22 UTC
puppet-2.6.6-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2011-09-27 18:32:45 UTC
puppet-2.6.6-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2011-09-27 22:59:38 UTC
puppet-2.6.6-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 19 Fedora Update System 2011-09-27 23:01:03 UTC
puppet-2.6.6-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.