Bug 666195 - Impossible to install 32bit and 64bit llvm at the same time
Impossible to install 32bit and 64bit llvm at the same time
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: llvm (Show other bugs)
14
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Michel Alexandre Salim
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-29 08:58 EST by Seppo Yli-Olli
Modified: 2011-04-04 23:01 EDT (History)
4 users (show)

See Also:
Fixed In Version: llvm-2.8-10.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-21 23:49:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Seppo Yli-Olli 2010-12-29 08:58:21 EST
Description of problem:

transaction Check Error:
  file /usr/share/doc/llvm-2.8/llvm-testlog.txt from install of llvm-2.8-5.fc14.i686 conflicts with file from package llvm-2.8-5.fc14.x86_64

Version-Release number of selected component (if applicable):
Name        : llvm
Arch        : x86_64
Version     : 2.8
Release     : 5.fc14

Name        : llvm
Arch        : i686
Version     : 2.8
Release     : 5.fc14


How reproducible:
Always

Steps to Reproduce:
1. yum install llvm.x86_64
2. yum install llvm.i686
  
Actual results:
Transaction failure

Expected results:
Get both versions of llvm

Additional info:
These two need to be capable to be installed at the same time because at a later point Mesa might end up depending on libllvm due to the llvmpipe software renderer in Gallium and you're supposed to be able to install both 32bit and 64bit Mesa.
Comment 1 Michel Alexandre Salim 2011-03-17 12:32:59 EDT
Good point, thanks. testlog.txt was generated in the past when some LLVM test cases actually failed, but should probably no longer be generated.
Comment 2 Fedora Update System 2011-03-17 15:19:13 EDT
llvm-2.8-9.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/llvm-2.8-9.fc15
Comment 3 Fedora Update System 2011-03-17 15:21:26 EDT
llvm-2.8-10.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/llvm-2.8-10.fc14
Comment 4 Fedora Update System 2011-03-17 15:23:07 EDT
llvm-2.8-10.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/llvm-2.8-10.fc13
Comment 5 Fedora Update System 2011-03-17 16:24:14 EDT
llvm-2.8-9.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/llvm-2.8-9.el6
Comment 6 Fedora Admin XMLRPC Client 2011-03-17 19:51:07 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 7 Fedora Update System 2011-03-21 23:49:27 EDT
llvm-2.8-10.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Seppo Yli-Olli 2011-03-24 14:50:42 EDT
Not sure if this is necessary but confirming that the LLVM in F14 updates-testing (2.8-10.fc14) no longer has this bug.
Comment 9 Fedora Update System 2011-03-27 15:28:45 EDT
llvm-2.8-10.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2011-03-27 15:29:07 EDT
llvm-2.8-10.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2011-04-04 23:00:54 EDT
llvm-2.8-10.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.