Bug 666335 - [abrt] claws-mail-3.7.8-2.fc14: parasite_python_init: Process /usr/bin/claws-mail was killed by signal 6 (SIGABRT)
Summary: [abrt] claws-mail-3.7.8-2.fc14: parasite_python_init: Process /usr/bin/claws-...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: claws-mail-plugins
Version: 14
Hardware: All
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Andreas Bierfert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:168899a5a4207513e34efaaff37...
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-30 08:45 UTC by Penelope Fudd
Modified: 2011-02-04 19:54 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2011-02-04 19:50:22 UTC


Attachments (Terms of Use)
File: backtrace (16.77 KB, text/plain)
2010-12-30 08:45 UTC, Penelope Fudd
no flags Details

Description Penelope Fudd 2010-12-30 08:45:09 UTC
abrt version: 1.1.14
architecture: i686
Attached file: backtrace
cmdline: claws-mail
component: claws-mail
crash_function: parasite_python_init
executable: /usr/bin/claws-mail
kernel: 2.6.35.10-74.fc14.i686
package: claws-mail-3.7.8-2.fc14
rating: 4
reason: Process /usr/bin/claws-mail was killed by signal 6 (SIGABRT)
release: Fedora release 14 (Laughlin)
time: 1293697144
uid: 0

comment
-----
Crash instantly on start.
Moving my .claws-mail directory out of the way prevented the crash, but it's got all my email accounts in it.

How to reproduce
-----
1. Upgraded from F12 to F14 (ie: copied home directory to fresh F14 install)
2. Installed all claws rpms
3. Started for first time

Comment 1 Penelope Fudd 2010-12-30 08:45:12 UTC
Created attachment 471157 [details]
File: backtrace

Comment 2 David Kovalsky 2011-01-05 13:39:21 UTC
Package: claws-mail-3.7.8-2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Configuration -> plugins
2. Load Python plugin (python.so)
3. Boom! (100% reproducible)


Comment
-----
# rpm -qa 'claws*'|sort
claws-mail-3.7.8-2.fc14.x86_64
claws-mail-plugins-fancy-3.7.8-1.fc14.x86_64
claws-mail-plugins-pgp-3.7.8-2.fc14.x86_64
claws-mail-plugins-python-3.7.8-1.fc14.x86_64
claws-mail-plugins-smime-3.7.8-2.fc14.x86_64

Comment 3 Michael Schwendt 2011-01-23 16:54:03 UTC
Temporarily, you can work around that by installing the "python-devel" package.

It is the Python plugin trying to dlopen libpython2.7.so instead of  libpython2.7.so.1.0.

A fix for the spec (plus a guard for the sed) would be this:

--- claws-mail-plugins.spec.ORIG        2011-01-23 14:10:54.000000000 +0100
+++ claws-mail-plugins.spec     2011-01-23 17:52:42.821191104 +0100
@@ -404,6 +404,10 @@
 
 #python
 cd ../python_plugin-%{python}
+# point the configure script at the right libpython file name because
+# the library will be dlopened at run-time
+grep 'PYTHON_VERSION}.so"' configure || exit -1
+sed -i -e 's!PYTHON_VERSION}.so"!PYTHON_VERSION}.so.1.0"!' configure
 %configure --disable-static --disable-dependency-tracking
 %{__make} %{?_smp_mflags}

Comment 4 Fedora Update System 2011-01-24 16:15:28 UTC
claws-mail-3.7.8-3.fc14,claws-mail-plugins-3.7.8-4.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/claws-mail-3.7.8-3.fc14,claws-mail-plugins-3.7.8-4.fc14

Comment 5 Fedora Update System 2011-01-24 16:18:04 UTC
claws-mail-3.7.8-3.fc13,claws-mail-plugins-3.7.8-4.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/claws-mail-3.7.8-3.fc13,claws-mail-plugins-3.7.8-4.fc13

Comment 6 Fedora Update System 2011-01-24 20:59:42 UTC
claws-mail-3.7.8-3.fc14, claws-mail-plugins-3.7.8-4.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update claws-mail claws-mail-plugins'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/claws-mail-3.7.8-3.fc14,claws-mail-plugins-3.7.8-4.fc14

Comment 7 David Kovalsky 2011-01-25 10:14:05 UTC
Loaded the Python plugin, played with the Python console. All worked fine on F14 without any crash. 

Thanks for the fix!

Comment 8 Fedora Update System 2011-02-04 19:50:08 UTC
claws-mail-3.7.8-3.fc14, claws-mail-plugins-3.7.8-4.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2011-02-04 19:54:28 UTC
claws-mail-3.7.8-3.fc13, claws-mail-plugins-3.7.8-4.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.