Bug 6664 - pppd dies immediately after running setup in rp3....
pppd dies immediately after running setup in rp3....
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: ppp (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-02 17:23 EST by java60
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-11-19 16:01:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description java60 1999-11-02 17:23:25 EST
After a GNOME workstation install, I ran rp3 to get onto
the 'net quick. The modem is internal but is successfully
detected and other info is entered. I used debug to try
the setup and the pppd product dies immediately. The modem
does dial successfully but no PAP secret is available (even
when it is..probably due to pppd death) and the system
hangs up and tries again. During the normal connection
process is fails in a continous try loop with hundreds of
messages in the "messages" log. I have since removed the
RH6.1 product but will reinstall and enter the "messaqes"
file entries.
Comment 1 java60 1999-11-02 21:06:59 EST
Using the debug session in rp3, the pppd dies with error code=1...I
am not sure what that means or where to find out
Comment 2 java60 1999-11-02 23:08:59 EST
Typo on the last entry...should be exit code=1. I also believe I
the answer to what the exit code it in the pppd man pages.
Exit code 1 means "An immediate fatal error of some kind occurred,
such as an essential call failing or running out of virtual memory."
Bummer!
Comment 3 java60 1999-11-03 00:14:59 EST
Did some sniffing around the other bug reports...fixed the
pppd error by taking out "lock" and putting in "noauth" in the
ppp options file....now to get the DNS lookup working...not
sure where that is either. I have also noticed the "first time
try to connect and works the second time" using the WvDial product.
I do connect but no DNS available....

------- Additional Comments From   11/03/99 00:34 -------
Heheheheh!...I am on the Internet with Red Hat 6.1 using Netscape..
added a couple of entries to the hosts file an voila...not
sure if this was the de riguer way but here I am.
Comment 4 java60 1999-11-03 19:36:59 EST
I guess I lucked out on getting the nameservice going. Looking for
the correct procedure for setting up DNS for dialup connections.
Any ideas??
Comment 5 Michael K. Johnson 1999-11-08 10:48:59 EST
Two problems.

The double-dial problem I believe to be fixed by my test release at
ftp://people.redhat.com/johnsonm/ppp-2.3.10-3.i386.rpm
I'll be releasing that as an errata update shortly.

The DNS problem (if I understand your report rightly) is a bug in
initscripts where it will replace nameserver entries in the
/etc/resolv.conf file, but not add entirely new ones.  We'll have
a new initscripts release shortly; in the meantime, you can fix
it with the command
echo 'nameserver
nameserver' >> /etc/resolv.conf
and then bring up your PPP connection again.

A possible third problem is if you are using CHAP authentication.
I think I know about another bug in initscripts that I will fix
and release an update for shortly.  Your fix of adding "noauth"
is equivalent to the fix that I intend to test as a possible fix.
Comment 6 java60 1999-11-08 11:23:59 EST
To clarify what happened and what I did.
After first install and setting up with RP3, I had no good
nameserver pointers anywhere and PPP died immediately. I manually
entered them after finding that resolv.conf was the place to put them
from Naba's Linux Secrets book covering 5.1. Entering them within the
setup screen of RP3 had no effect. I found the "noauth" entry fix that
allowed the PPP product to run in another bug report. The dialer still
dials twice. I have no idea what that is but I know if your connect
(turn on the interface) from within Linuxconf, it only dials once.
Comment 7 java60 1999-11-08 12:38:59 EST
I inadvertantly got -2 of that .rpm file. It fixed the problem the
dial twice problem also.
I will get -3 and see if there is any other change. Thanks
Comment 8 Michael K. Johnson 1999-11-08 14:14:59 EST
Right, now that you have entered some addresses into resolv.conf,
they will be automatically updated as long as your ISP provides
the new addresses via the msdns extension.

The -3 seems to work for everyone else, so I'm in the process of
releasing it as an errata release.

The "noauth" will be fixed in the same release as the DNS fix.
Comment 9 java60 1999-11-08 19:01:59 EST
Okay, here is what I am getting with either one (might be old conf.
files. I will try to resetup with RP3 as if it is new) of the
ppp.blahblah.rpm version -2 or -3. When I run the applet to connect,
it does connect the first time, put the little window that comes up
that shows activity still asks you if you want to connect and has
no activity (red or green) and the little speed and timer are not
moving even though I am online. The second try the same thing. The
third try the same and it crashed once there. The fourth try the
activity lines appear in the little monitor window, the clock runs and
the online xfer speed is indicated correctly. Also when you run the
mouse across it, it asks you if you want to disconnect which is
correct. This is with either -2 or -3...I am going in to look around
and see if old dregs are wrecking this...be back in a bit.
Comment 10 Michael K. Johnson 1999-11-09 09:30:59 EST
rp3 is a completely separate program from ppp.  Installing a new
version of ppp won't change rp3's behaviour; the only change in
behaviour you will see in rp3 is where it is telling you about
pppd's behaviour.

Have you upgraded to rp3-1.0.1 yet?
Comment 11 java60 1999-11-09 10:20:59 EST
Crap, it worked perfect this morning the first time in after boot
up....anyway, yes I understand they are not the same. It appears this
process involves rp3 as the setup tool, wvdial as the dialer and ppp
as the interface handler. Is that about right? Which one is the little
display window that indicates traffic on that the ppp interface part
of? I will check my version of each. Now if I can get the product to
see my printer port on the mobo...it just can't find it period..but
that is a different issue..thanks.
Comment 12 java60 1999-11-09 10:34:59 EST
I have rp3-1.0.1-1, ppp2.3.10-2 (I think -3 weirded out on me and I
moved back to -2 but let me be sure this is working right and then I
will move on to -3 after I boot up a few times and start the interface
sucessfully on one try.) and wvdial 1.40-5.
Comment 13 Michael K. Johnson 1999-11-19 16:01:59 EST
wvdial does the dialing, pppd (in the ppp package) negotiates the PPP
protocol and calls wvdial to do the dialing, rp3 (in the rp3 package)
gives the cute window with the scrolling graphics and the popup-menus
to start and stop, and rp3-config (in the rp3 package) is the program
that actually sets up the configuration.  We try to make it look as
much as possible like a part of rp3; the original intent was to
engender less confusion, although I don't know if we succeeded at that.

Every other similar report is that the -3 pppd fixes this problem.
I'll close this bug report; please re-open if that's not the case.
Thanks!

Note You need to log in before you can comment on or make changes to this bug.