Bug 666462 - [NVa5] Brightness (backlight) control madness on Lenovo W510
[NVa5] Brightness (backlight) control madness on Lenovo W510
Status: CLOSED DUPLICATE of bug 625171
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
14
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
: Patch, Regression, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-30 18:46 EST by David Kovalsky
Modified: 2014-03-31 19:46 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-06 18:53:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/var/log/Xorg.0.log (79.24 KB, text/plain)
2010-12-30 18:46 EST, David Kovalsky
no flags Details
gnome-power-manager --verbose output (20.39 KB, text/plain)
2010-12-30 18:51 EST, David Kovalsky
no flags Details

  None (edit)
Description David Kovalsky 2010-12-30 18:46:21 EST
Created attachment 471224 [details]
/var/log/Xorg.0.log

After upgrading from F13 to F14 backlight (brightness) control on Lenovo W510 notebook got totally mad. There are a couple of issues: 

- after boot the display is too dark. I'm barely able to see the letters, but the brightness control shows me I'm at the max. 

- curiously, after plugging/unplugging the power connector the display goes to very-very-max bright, that I'm used to from F13. 

- BUT, after I try to take the brightness down just by one level I go back to pretty dark (like just after boot). 

kernel-2.6.35.10-74.fc14.x86_64
xorg-x11-drv-nouveau-0.0.16-13.20101010git8c8f15c.fc14.x86_64

Attaching a couple of logs, please ask for more if I haven't supplied the right ones.
Comment 1 David Kovalsky 2010-12-30 18:51:43 EST
Created attachment 471225 [details]
gnome-power-manager --verbose output

As a regular user, executed `killall gnome-power-manager'. 

Then `gnome-power-manager --verbose | tee gpm.log' (which is attached). 

+ I've just noticed I can't find the brightness applet I've used in F13 + Gnome.
Comment 2 David Kovalsky 2010-12-30 18:56:17 EST
JFTR, Xorg server version:
xorg-x11-server-Xorg-1.9.3-3.fc14.x86_64
Comment 3 David Kovalsky 2010-12-30 19:21:56 EST
Found this in /var/log/messages, if relevant:

thinkpad_acpi: Standard ACPI backlight interface available, not loading native one.
Comment 4 David Kovalsky 2010-12-31 06:31:56 EST
Tried booting into F13 kernel 2.6.34.7-66.fc13.x86_64, the brightness is at the max. But I'm unable to adjust it by the brigtness keys. 

And the helper app prints a nonsense current value. 

HTH.


$ gnome-power-backlight-helper --get-brightness
1073782252

$ gnome-power-backlight-helper --get-max-brightness
1025
Comment 5 Benedikt Morbach 2011-01-07 10:46:13 EST
I had exactly this issue when I installed F14, but worked around it by using the proprietary binary blob from nvidia.

I believe the correct solution is this commit from upstream:
http://cgit.freedesktop.org/nouveau/linux-2.6/patch/?id=fcd4800dd07f0e7923b91e8a9f745f3c2a0e1dda

As this doesn't look as if it would break anything, maybe it could be added as a patch to Fedora's kernel.

This bug is probably related and the patch in there is also a viable workaround, iirc:
https://bugzilla.redhat.com/show_bug.cgi?id=625171
Comment 6 David Kovalsky 2011-01-07 11:02:30 EST
I can confirm that brightness is at the max with nvidia binary blob. Downside to that is that I can't manage brightness (it's always at the max).
Comment 7 Benedikt Morbach 2011-01-08 18:08:26 EST
I just removed the binary blob and built a new kernel using the above upstream patch[1]. Brightness control now works as expected.
Note that rawhide isn't affected, probably because the patch already is upstream[2]. (included in 2.6.37)

This should probably be rolled out as an update for F14.
This would probably also fix [3] (maybe it this even is a duplicate)

As the fix is a kernel patch, should this bug be reassigned to Fedora/kernel?

[1] http://cgit.freedesktop.org/nouveau/linux-2.6/patch/?id=fcd4800dd07f0e7923b91e8a9f745f3c2a0e1dda
[2] http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=5bead799d3f8f1500c4b59301b8a2732a92f559f
[3] https://bugzilla.redhat.com/show_bug.cgi?id=625171

btw, you can also get brightness control when using the blob, by setting
Option	"RegistryDwords" "EnableBrightnessControl=1"
in the "Device" Section of your xorg.conf
Comment 8 Aaron 2011-03-10 22:14:45 EST
(In reply to comment #7)
> I just removed the binary blob and built a new kernel using the above upstream
> patch[1]
>
> [1]
> http://cgit.freedesktop.org/nouveau/linux-2.6/patch/?id=fcd4800dd07f0e7923b91e8a9f745f3c2a0e1dda

This may be a total n00b question, but how do I apply this patch?

Thanks
Comment 9 Christopher Heiny 2011-04-06 02:03:12 EDT
I am also experiencing this issue.  When can we expect to see an updated kernel?
Comment 10 Ben Skeggs 2011-04-06 18:53:20 EDT

*** This bug has been marked as a duplicate of bug 625171 ***

Note You need to log in before you can comment on or make changes to this bug.