Bug 666544 - verify behaviour of subscription-manager facts --list when system is not registered
Summary: verify behaviour of subscription-manager facts --list when system is not regi...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.1
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: rc
: ---
Assignee: Bryan Kearney
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks: Entitlement-Beta
TreeView+ depends on / blocked
 
Reported: 2010-12-31 15:34 UTC by John Sefler
Modified: 2011-05-19 13:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-19 13:38:27 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2011:0611 normal SHIPPED_LIVE new package: subscription-manager 2011-05-18 17:56:21 UTC

Description John Sefler 2010-12-31 15:34:41 UTC
Description of problem:
Despite VERIFIED bugzilla https://bugzilla.redhat.com/show_bug.cgi?id=654429 there is a change in behaviour for "subscription-manager facts --list" when the system has not been registered.

In bugzilla 654429, the "subscription-manager facts --list" was verified to block output with "Consumer not registered" when the system is not registered.

Today "subscription-manager facts --list" does not block when the system is not registered.

Personally, I feel that today's behaviour is correct.

I simply want to verify that this change is behaviour was done by design and is NOT a regression.


Version-Release number of selected component (if applicable):

[root@jsefler-onprem01 ~]# rpm -q subscription-manager
subscription-manager-0.93.8-1.git.15.dfe034e.el6.x86_64


Steps to Reproduce:
[root@jsefler-onprem01 ~]# subscription-manager unregister
This system is currently not registered.

[root@jsefler-onprem01 ~]# subscription-manager facts --list
cpu.architecture: x86_64
cpu.core(s)_per_socket: 1
cpu.cpu(s): 2
cpu.cpu_family: 6
cpu.cpu_mhz: 2300.022
cpu.cpu_op-mode(s): 64-bit
cpu.cpu_socket(s): 2
cpu.hypervisor_vendor: KVM
cpu.l1d_cache: 64K
cpu.l1i_cache: 64K
cpu.l2_cache: 512K
cpu.model: 2
cpu.numa_node(s): 1
cpu.numa_node0_cpu(s): 0,1
cpu.stepping: 3
cpu.thread(s)_per_core: 1
cpu.vendor_id: AuthenticAMD
cpu.virtualization_type: full
distribution.id: Santiago
distribution.name: Red Hat Enterprise Linux Server
distribution.version: 6.0
dmi.bios.address: 0xe8000
dmi.bios.bios_revision: 1.0
dmi.bios.relase_date: 01/01/2007
dmi.bios.rom_size: 64 KB
dmi.bios.runtime_size: 96 KB
dmi.bios.vendor: QEMU
dmi.bios.version: QEMU
dmi.chassis.asset_tag: Not Specified
dmi.chassis.boot-up_state: Safe
dmi.chassis.lock: Not Present
dmi.chassis.manufacturer: Not Specified
dmi.chassis.power_supply_state: Safe
dmi.chassis.security_status: Unknown
dmi.chassis.serial_number: Not Specified
dmi.chassis.thermal_state: Safe
dmi.chassis.type: Other
dmi.chassis.version: Not Specified
dmi.memory.array_handle: 0x1000
dmi.memory.bank_locator: Not Specified
dmi.memory.data_width: 64 bit
dmi.memory.error_correction_type: Other
dmi.memory.error_information_handle: Not Provided
dmi.memory.form_factor: DIMM
dmi.memory.location: Other
dmi.memory.locator: DIMM 0
dmi.memory.maximum_capacity: 1 GB
dmi.memory.size: 1024 MB
dmi.memory.speed:   (ns)
dmi.memory.total_width: 64 bit
dmi.memory.type: RAM
dmi.memory.use: System Memory
dmi.processor.family: Other
dmi.processor.socket_designation: CPU 1
dmi.processor.status: Populated:Enabled
dmi.processor.type: Central Processor
dmi.processor.upgrade: Other
dmi.processor.version: Not Specified
dmi.processor.voltage:  
dmi.system.family: Not Specified
dmi.system.manufacturer: Not Specified
dmi.system.product_name: Not Specified
dmi.system.serial_number: Not Specified
dmi.system.sku_number: Not Specified
dmi.system.status: No errors detected
dmi.system.uuid: 7ad7bdea-5fd9-885b-d01c-d06c698adad7
dmi.system.version: Not Specified
dmi.system.wake-up_type: Power Switch
events.test.currentTimeMillis: 1293784212907
events.test.description: Testing CONSUMER MODIFIED event fires on facts update.
memory.memtotal: 1019568
memory.swaptotal: 2064376
net.interface.eth0.broadcast: 10.16.120.255
net.interface.eth0.hwaddr: 52:54:00:65:aa:29
net.interface.eth0.ipaddr: 10.16.120.247
net.interface.eth0.netmask: 255.255.255.0
net.interface.lo.broadcast: 0.0.0.0
net.interface.lo.hwaddr: 00:00:00:00:00:00
net.interface.lo.ipaddr: 127.0.0.1
net.interface.lo.netmask: 255.0.0.0
network.hostname: jsefler-onprem01.usersys.redhat.com
network.ipaddr: 127.0.0.1
uname.machine: x86_64
uname.nodename: jsefler-onprem01.usersys.redhat.com
uname.release: 2.6.32-71.7.1.el6.x86_64
uname.sysname: Linux
uname.version: #1 SMP Wed Oct 27 03:44:59 EDT 2010
virt.host_type: kvm
virt.is_guest: True


[root@jsefler-onprem01 ~]# subscription-manager facts --update
Consumer not registered. Please register using --username and --password
[root@jsefler-onprem01 ~]#

Comment 2 John Sefler 2010-12-31 16:36:28 UTC
Upon further review, it looks like the subscription-manager facts --list change in behaviour was purposefully introduced by jharris here: https://bugzilla.redhat.com/show_bug.cgi?id=661329

Comment 3 Adrian Likins 2011-01-03 16:07:22 UTC
Current behaviour seems correct to me. facts --list is purely local, so should work sans registration.

Comment 4 John Sefler 2011-01-03 17:59:06 UTC
Agreed.  Moving to VERIFIED.

Comment 5 errata-xmlrpc 2011-05-19 13:38:27 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2011-0611.html


Note You need to log in before you can comment on or make changes to this bug.