Bug 66657 - installer reports Unresolved Dependencies with "No Suggestions"
installer reports Unresolved Dependencies with "No Suggestions"
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-13 01:22 EDT by Douglas Wooster
Modified: 2007-04-18 12:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-28 19:06:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Douglas Wooster 2002-06-13 01:22:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.3 (X11; Linux i686; U;) Gecko/20020523

Description of problem:
Doing an Upgrade install from RH 6.1+, customized list of packages to install,
the Unresolved Dependencies panel reported several packages to each have a
dependency on "No Suggestions":

What the Unresolved Dependencies panel displayed for them:

  Package	
	Requires
  ----------------------------- ---------------------
	 ...
		       ...
  kpackage	
	no suggestion
  aktion	
	no suggestion
  linuxconf	
	no suggestion
  rpm-devel	
	no suggestion
  pilot-link	
	no suggestion
  mtv-fullscreen-extension	no suggestion

Some of these packages aren't even being installed (e.g. linuxconf isn't even
included on the RH 7.3 CD's).




Version-Release number of selected component (if applicable):


How reproducible:
Always
(I cancelled the first install and openned Service Request 206004.  Reran the
install and got the same results.  I did not attempt to reinstall RH 6.1 and
reupgrade to 7.3, however)


Steps to Reproduce:
1.Install RH 6.1.
2.Start an Upgrade install to RH 7.3
3.Choose to customize the list of packages to install (I'm not sure, but I don't
think it makes much difference, whether you change the list of packages from the
default, or not)
4.Observe that the Unresolved Dependencies page lists "no suggestions"
dependencies for several packages, including some that aren't being installed.
	

Actual Results:  The Unresolved Dependencies panel listed the following strange
dependencies for several packages, some of which are not even being installed:

  Package	
	Requires
  ----------------------------- ---------------------
	 ...
		       ...
  kpackage	
	no suggestion
  aktion	
	no suggestion
  linuxconf	
	no suggestion
  rpm-devel	
	no suggestion
  pilot-link	
	no suggestion
  mtv-fullscreen-extension	no suggestion

There were also several legitimate unresolved dependencies listed.  I went back
to the package selection panels to resolve those.  In the end, I could not get
rid of these six, and had to choose to ignore them.


Expected Results:  One of the following:

A) If there are real dependencies involving the "no suggestions" packages
(including the case where an already-installed package is dependent upon
something which the upgrade install will remove), then thoese dependencies
should be reported.  Probably there should be a separate listing for
already-installed packages which will become broken because something they're
dependent upon will be removed by the install.

or

B) If there aren't any real dependencies, then the package should not be listed
as having an Unresolved Dependency.


Additional info:

This was originally Service Request 206004.  The support rep. said that it
should be reported here.
Comment 1 Jeremy Katz 2003-07-28 19:06:43 EDT
These don't get reported anymore (since there's nothing we can do about them)

Note You need to log in before you can comment on or make changes to this bug.