Bug 666612 - new release of x11vnc 0.9.12 is available that might allow successful build.
Summary: new release of x11vnc 0.9.12 is available that might allow successful build.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: x11vnc
Version: rawhide
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Pavel Alexeev
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-01-01 13:28 UTC by David Timms
Modified: 2011-02-10 17:54 UTC (History)
1 user (show)

Fixed In Version: x11vnc-0.9.12-17.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-01-18 13:59:11 UTC


Attachments (Terms of Use)

Description David Timms 2011-01-01 13:28:24 UTC
Description of problem:
A later release of x11vnc has been made. It might resolve the build problem for pyvnc2swf on EL6, that I'm having trouble with.

Version-Release number of selected component (if applicable):
x11vnc-0.9.8-14.fc13.x86_64

How reproducible:
Yes.

Steps to Reproduce:
1. Try to build x11vnc that is in current el6 branch
2. Fails: http://koji.fedoraproject.org/koji/watchlogs?taskID=2695529
  
Actual results:
if gcc -DHAVE_CONFIG_H -I. -I. -I.. -I..      -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -Wall -MT x11vnc-inet.o -MD -MP -MF ".deps/x11vnc-inet.Tpo" -c -o x11vnc-inet.o `test -f 'inet.c' || echo './'`inet.c; \
	then mv -f ".deps/x11vnc-inet.Tpo" ".deps/x11vnc-inet.Po"; else rm -f ".deps/x11vnc-inet.Tpo"; exit 1; fi
cleanup.c: In function 'Xerror':
cleanup.c:288: error: 'X_ShmAttach' undeclared (first use in this function)
cleanup.c:288: error: (Each undeclared identifier is reported only once
cleanup.c:288: error: for each function it appears in.)
cleanup.c: In function 'crash_shell':
...

Expected results:
success.

Additional info:
Seems that it has been unable to build in el6 between since 2010-12-11, stopping me being able to build pyvnc2swf.

I found an identical error in launchpad package:
https://bugs.launchpad.net/ubuntu/+source/x11vnc/+bug/497941
It seems they moved to upstream release 0.9.9 to resolve. In fact upstream is now at 0.9.12, with a 0.9.13 beta release.

might be useful as well:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=598619

If you would like me to comaintain, please indicate, and I'll add request in packagedb.

Comment 1 Pavel Alexeev 2011-01-02 09:50:19 UTC
Hm.

As you can see in rawhide already 0.9.12 version since Oct 30 2010.
And it is built correctly on RHEL6, except ppc64 arch - http://koji.fedoraproject.org/koji/taskinfo?taskID=2696183. On PPC64 is standart global problem - java missing.

P.S. I always want help by requests. But if you really want become co-maintainer - always welcome!

Comment 2 David Timms 2011-01-02 12:17:20 UTC
(In reply to comment #1)
> As you can see in rawhide already 0.9.12 version since Oct 30 2010.
I was looking at:
https://admin.fedoraproject.org/community/?package=x11vnc#package_maintenance
, where it seems the rawhide version is still 0.9.8-14.fc13. 

Is that not accurate ?

> And it is built correctly on RHEL6, except ppc64 arch -
> http://koji.fedoraproject.org/koji/taskinfo?taskID=2696183. On PPC64 is
> standart global problem - java missing.
Do you know what the process for the ppc64 java problem will be ?

Are we waiting on a successful java build ?

Or will it be removed entirely from ppc64, and we then need to exclude arch ppc64 from the builds of x1vnc and hence pyvnc2swf ?
Actually, found a thread that relates to this:
http://thread.gmane.org/gmane.linux.redhat.fedora.epel.devel/5761

Perhaps we should keep this open as a reminder to rebuild once the above problem is solved.

By the way: we are supposed to reset the -release counter back to 1,once the version is updated, ie this updated build should have been 0.9.12-1. Unfortunately, it can't be fixed now, you'll need to wait until you package the next version.

Comment 3 Pavel Alexeev 2011-01-02 16:09:18 UTC
Uppps, sorry David. Indeed I forgot commit it an build not scratch.
Now it in rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=2696346

Comment 4 David Timms 2011-01-13 21:31:32 UTC
Since EPEL is nearing release:
http://thread.gmane.org/gmane.linux.redhat.fedora.epel.devel/5859
http://article.gmane.org/gmane.linux.redhat.fedora.epel.devel/5862

Would you mind making the addition of:
ExcludeArch: ppc64

in the EL-6 branch spec, and building. This will allow pyvnc2swf to also be built.

Thanks.

Comment 5 Pavel Alexeev 2011-01-14 14:21:51 UTC
ExcludeArch: ppc64 you are meaning add only to javaviewers subpackage?
And you are sure? I ask in devel list about ppc64 java in EPEL, but got answer now have not made desicion about it and announce will.

Comment 6 David Timms 2011-01-15 04:43:25 UTC
(In reply to comment #5)
> ExcludeArch: ppc64 you are meaning add only to javaviewers subpackage?
I looked at your infrastructure ticket for EPEL 5. I don't know without trying whether EPEL 6 rpm can create exclude arched subpackages, but would seem to be the current best solution for x11vnc; then at least the main package is usable on all arches, even though the ppc64 javaviewers is not working.

> And you are sure? I ask in devel list about ppc64 java in EPEL, but got answer
> now have not made desicion about it and announce will.
That is what Kevin alluded to in the links I provided in comment 4.

Summarizing, unless someone can spend a whole lot of time to get ppc64 java working in the next day, then packages requiring java while need to instead excludearch.

So, yes, go ahead and make the changes.

Comment 7 Pavel Alexeev 2011-01-18 13:43:54 UTC
Ok, I'll do it.

Comment 8 Pavel Alexeev 2011-01-18 13:59:11 UTC
Built http://koji.fedoraproject.org/koji/taskinfo?taskID=2728535

Comment 9 David Timms 2011-01-25 22:41:04 UTC
(In reply to comment #8)
> Built http://koji.fedoraproject.org/koji/taskinfo?taskID=2728535

Hi Pavel. Just to let you know that I have run pyvnc2swf with that build, and it works (although, this is on Fedora 14, since my rhelbeta system wont boot anymore).

Can you please request an el6 updates-testing push ?

Comment 10 Pavel Alexeev 2011-01-26 08:57:25 UTC
Hm, I beleave what on moment of built it was inb testing and no updates needed. Sorry if not so. I try do it now.

Comment 11 Fedora Update System 2011-01-26 08:57:32 UTC
x11vnc-0.9.12-17.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/x11vnc-0.9.12-17.el6

Comment 12 Fedora Update System 2011-02-10 17:54:37 UTC
x11vnc-0.9.12-17.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.