Bug 666631 - [abrt] xu4-1.1-0.8.20100119svn2725.fc13: Weapon::getType: Process /usr/bin/u4.bin was killed by signal 11 (SIGSEGV)
Summary: [abrt] xu4-1.1-0.8.20100119svn2725.fc13: Weapon::getType: Process /usr/bin/u4...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xu4
Version: 14
Hardware: x86_64
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Jason Tibbitts
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:2f2608d953d4d125ba6f2d73f18...
: 691852 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-01-01 17:39 UTC by Jean Gobin
Modified: 2011-04-15 21:48 UTC (History)
3 users (show)

Fixed In Version: xu4-1.1-0.14.20110329svn2873.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-04-08 23:20:07 UTC


Attachments (Terms of Use)
File: backtrace (6.39 KB, text/plain)
2011-01-01 17:40 UTC, Jean Gobin
no flags Details

Description Jean Gobin 2011-01-01 17:39:58 UTC
abrt version: 1.1.14
architecture: x86_64
Attached file: backtrace
cmdline: /usr/bin/u4.bin -f
component: xu4
crash_function: Weapon::getType
executable: /usr/bin/u4.bin
kernel: 2.6.35.10-74.fc14.x86_64
package: xu4-1.1-0.8.20100119svn2725.fc13
rating: 4
reason: Process /usr/bin/u4.bin was killed by signal 11 (SIGSEGV)
release: Fedora release 14 (Laughlin)
time: 1293903374
uid: 500

How to reproduce
-----
1. Just got ressucited 
2. (r)eady weapon (no weapon available other than A- Hands)
3. Ready (A)
4. Press enter

Comment 1 Jean Gobin 2011-01-01 17:40:00 UTC
Created attachment 471340 [details]
File: backtrace

Comment 2 Ruben 2011-01-15 16:46:57 UTC
Package: xu4-1.1-0.8.20100119svn2725.fc13
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Excicuted the program
2.pressed E to exit
3.

Comment 3 Jason Tibbitts 2011-01-15 18:10:23 UTC
The program doesn't accept 'E' from the start screen.  I'm afraid none of the instructions for reproducing this are very helpful, and I'll have no choice but to close this ticket unless I get some which actually allow me to reproduce this problem.

Comment 4 Jason Tibbitts 2011-01-20 01:00:09 UTC
It seems that, after quite some time, upstream is now showing signs of life.  I passed this bug on and it's supposedly been fixed.  Unfortunately there are other changes which prevent me from just pushing a current build right out, mainly in that upstream has changed the music to using impulsetracker which may or may not work.

Here's a completely untested scratch build.  Please try it out and let me know if it helps (or if other things break):
  http://koji.fedoraproject.org/koji/taskinfo?taskID=2732388

Comment 5 Jason Tibbitts 2011-02-24 19:44:11 UTC
Well, no response.  Still don't have any useful instructions for reproducing this so I'm just going to close it.  Since upstream has restarted development and indicated that they believe that a similar backtrace was fixed, hopefully the version in F15 will not have this issue.

Comment 6 Jason Tibbitts 2011-03-29 17:10:18 UTC
*** Bug 691852 has been marked as a duplicate of this bug. ***

Comment 7 Ed Marshall 2011-03-29 17:51:06 UTC
I rebuilt the version that's about to ship with F15 and gave it a try, but it looks like the problem still persists (the one I reported in the other bug).

Reproduction recipe:
- start by removing/relocating $HOME/.xu4 temporarily
- run u4, "accept", "accept", "start" (to install the necessary files).
- From the main screen, hit return until menu appears.
- Select "Initiate New Game" (I), enter a name, pick a gender.
- Hit return until asked to pick cards. Keep hitting "A". ;)
- When the world screen appears, type "W", and rather than selecting anything, simply press return.

The game will segfault at that point.

Comment 8 Ed Marshall 2011-03-29 17:52:40 UTC
Looks like the same result for the "R" (ready weapon) command as well: hit "R", then hit return instead of selecting an item from inventory.

Comment 9 Jason Tibbitts 2011-03-29 18:08:15 UTC
Looks like upstream wasn't correct; this is still an issue as of that snapshot.  They've been doing pretty continuous work lately, so I'll pull in another snapshot and see if it helps.

Comment 10 Jason Tibbitts 2011-03-29 18:13:30 UTC
Unfortunately the latest SVN code fails to build for me, so I'll have to track that down first.

Comment 11 Jason Tibbitts 2011-03-29 19:05:51 UTC
Needed a bit of patching to build, but the problem is still there.  Reported upstream.

Unfortunately it's also missing the music for some reason.  Also trying to track that down.

Comment 12 Jason Tibbitts 2011-03-30 02:33:42 UTC
OK, upstream committed a fix and it seems to work for me.  I'll be pushing fresh builds out to testing; karma will be appreciated (though I suspect you may be the only person actively using this package).

Comment 13 Fedora Update System 2011-03-30 02:40:30 UTC
xu4-1.1-0.14.20110329svn2873.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/xu4-1.1-0.14.20110329svn2873.fc15

Comment 14 Fedora Update System 2011-03-30 02:48:52 UTC
xu4-1.1-0.14.20110329svn2873.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/xu4-1.1-0.14.20110329svn2873.fc14

Comment 15 Ed Marshall 2011-03-30 14:12:15 UTC
I think you're probably right about me being one of the few people interested in this right now; I was inspired to fire it back up after seeing a round of online news articles about the Ultima franchise recently. ;-)

Anyway, with this update, the problem appears to be resolved (and I discovered that fedora-easy-karma doesn't support SOCKS5 proxies ;-). Thanks for looking at it!

Comment 16 Fedora Update System 2011-03-30 19:55:57 UTC
Package xu4-1.1-0.14.20110329svn2873.fc14:
* should fix your issue,
* was pushed to the Fedora 14 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xu4-1.1-0.14.20110329svn2873.fc14'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/xu4-1.1-0.14.20110329svn2873.fc14
then log in and leave karma (feedback).

Comment 17 Fedora Update System 2011-04-08 23:20:01 UTC
xu4-1.1-0.14.20110329svn2873.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2011-04-15 21:48:24 UTC
xu4-1.1-0.14.20110329svn2873.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.