Bug 666687 - [patch] xsane support for Brother MFC-290-C
[patch] xsane support for Brother MFC-290-C
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sane-backends (Show other bugs)
6.0
All Linux
medium Severity medium
: rc
: ---
Assigned To: Nils Philippsen
BaseOS QE - Apps
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-02 05:32 EST by Alexander Todorov
Modified: 2012-07-09 08:07 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 498228
Environment:
Last Closed: 2012-07-09 06:10:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to add MFC-290C support (537 bytes, patch)
2011-01-02 05:34 EST, Alexander Todorov
no flags Details | Diff

  None (edit)
Description Alexander Todorov 2011-01-02 05:32:07 EST
+++ This bug was initially created as a clone of Bug #498228 +++

Description of problem:
Trying to scan images using xsane with a Brother scanner fails when running as non-root user. After accepting the program license an error is shown:

Failed to open device `brother3:bus1;dev1': Error during device I/O.

Version-Release number of selected component (if applicable):
xsane-0.991-5.el5
Brother MFC-290C scanner with brscan3-0.2.5-2 driver

How reproducible:
Always on that particular hardware

Steps to Reproduce:
1. Start xsane as normal user
2. Accept the user licence

  
Actual results:
Error dialog:
Failed to open device `brother3:bus1;dev1': Error during device I/O.

Expected results:
xsane starts and works

Additional info:
Running xsane as root work properly and I'm able to scan images and save the resulting files.

The device is connected via USB and the above error points me to:
$ ls -l /dev/bus/usb/001/001 
crw-r--r-- 1 root root 189, 0 29 апр 16,28 /dev/bus/usb/001/001

This appears to be access permissions issue.

SELinux is in enforcing mode but no denials occur /it should not be SELinux issue/.

brscan3 is a sane backend driver from the manufacturer and it works apparently when running as root.

--- Additional comment from atodorov@redhat.com on 2009-04-29 17:32:12 EEST ---

This is preventing regular users to use the scanner locally. They have to execute xsane with root parmissions which is not desirable. 

I can do the testing since I have the device required.

--- Additional comment from pknirsch@redhat.com on 2009-05-12 16:30:26 EEST ---

Isn't the device created by udev? If so then i think this is rather a udev problem than a xsane problem and we should change the component.

Thanks & regards, Phil

--- Additional comment from atodorov@redhat.com on 2009-05-12 16:40:28 EEST ---

(In reply to comment #2)
> Isn't the device created by udev? If so then i think this is rather a udev
> problem than a xsane problem and we should change the component.
> 

I wasn't quite sure which was the correct component. Feel free to change it if you think udev is the correct one.

--- Additional comment from pknirsch@redhat.com on 2009-05-12 18:28:36 EEST ---

Adding Harald Hoyer (udev maintainer) to the bug so he can comment on it before we possibly switch the component.

Thanks & regards, Phil

--- Additional comment from harald@redhat.com on 2009-05-12 18:48:03 EEST ---

I think the vendor/device ids are missing in /etc/udev/rules.d/60-libsane.rules 

$ rpm -qf /etc/udev/rules.d/60-libsane.rules 
sane-backends-1.0.18-5.el5

You could quickfix it by duplicating an entry with the correct ids.

--- Additional comment from pknirsch@redhat.com on 2009-05-18 15:33:10 EEST ---

For that we'd need the details for that scanner though, putting in NEEDINFO

Thanks & regards, Phil

--- Additional comment from atodorov@redhat.com on 2009-05-18 15:50:14 EEST ---

What info do you need and where/how to find it? What should be inside /etc/udev/rules.d/60-libsane.rules ?

--- Additional comment from pknirsch@redhat.com on 2009-05-18 18:18:29 EEST ---

The file /etc/udev/rules.d/60-libsane.rules can be found in the sane-backends package.

The format looks like this:

# Brother FAX-2900
SYSFS{idVendor}=="04f9", SYSFS{idProduct}=="0117", SYMLINK+="scanner-%k"

So we basically need the SYSFS vendor ID and the SYSFS product ID.

I just checked and the Brother MFC-290C doesn't seem to be in there yet.

So i've moved this bug to the sane-backends component as the change needs to go in there.

Thanks & regards, Phil

--- Additional comment from atodorov@redhat.com on 2009-05-19 11:06:30 EEST ---

Created attachment 344586 [details]
patch for /etc/udev/rules.d/60-libsane.rules

The above patch works for me. I'm able to start xsane as normal user.

--- Additional comment from pknirsch@redhat.com on 2009-05-19 15:17:46 EEST ---

Thanks Alexander! Patch looks good, granting Devel ACK.

Regards, Phil

--- Additional comment from pknirsch@redhat.com on 2009-05-21 19:23:09 EEST ---

Hm. As sane-backends is not an approved component and the deadline for FT erratas for RHEL-5.4 has run out i'll be reflagging it to RHEL-5.5 FT so that we won't forget about it for 5.5.

Thanks & regards, Phil

PS: And yes, imo the change is small and simple enough to make this a viable FT errata.

--- Additional comment from pknirsch@redhat.com on 2009-12-22 16:54:23 EET ---

Moving to RHEL-5.6 FT.

Thanks & regards, Phil

--- Additional comment from pm-rhel@redhat.com on 2010-10-05 11:04:34 EEST ---

This request is not going to be addressed in RHEL 5.6 FasTrack.

--- Additional comment from atodorov@redhat.com on 2010-10-05 11:28:02 EEST ---

Update summary and request for 5.7.
Comment 1 Alexander Todorov 2011-01-02 05:34:32 EST
Created attachment 471376 [details]
patch to add MFC-290C support

Cloning here for RHEL6:
sane-backends-1.0.21-3.el6.i686

The file which needs patch is now located in /lib/udev/rules.d/65-libsane.rules.

The modified patch is attached. It works for me.
Comment 2 Suzanne Yeghiayan 2011-02-15 16:46:29 EST
This issue was proposed for RHEL 6.1 FasTrack but did not get resolved in time.
It has been moved to RHEL 6.2 FasTrack.
Comment 6 RHEL Product and Program Management 2011-08-19 14:09:04 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Note You need to log in before you can comment on or make changes to this bug.