Bug 66687 - latitude c400 (i830 graphics card) shows weird display artifacts even in 8 bit mode
latitude c400 (i830 graphics card) shows weird display artifacts even in 8 bi...
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-13 12:36 EDT by Raphael Clifford
Modified: 2007-04-18 12:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-24 02:17:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The restults of running lspci -vv (5.84 KB, text/plain)
2003-01-21 17:49 EST, Raphael Clifford
no flags Details
lspci -vvn results (5.12 KB, text/plain)
2003-01-21 17:50 EST, Raphael Clifford
no flags Details
X server log (23.10 KB, text/plain)
2003-01-22 07:04 EST, Raphael Clifford
no flags Details
X config file (3.37 KB, text/plain)
2003-01-22 07:05 EST, Raphael Clifford
no flags Details

  None (edit)
Description Raphael Clifford 2002-06-13 12:36:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.0rc3) Gecko/20020524

Description of problem:
Using http://www.cse.unsw.edu.au/~chak/linux/XF86Config-4.c400 as the XF86Config
file I get strange rectangular display artifacts. This occurs, for example, at
the X login screen (where the redhat logo is decapitated) and when I run
mozilla.  A screen shot of the later case is at
http://genomes.rockefeller.edu/~clifford/display_bug.png. This is in 8 bit mode
which is supposed to work I hear.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Copy the XF86Config file mentioned above
2. start X.
3. Look at decapitated Redhat logo at the X login screen
4. loging and start mozilla, for example
5. Look at strange display artifacts in mozilla (see
http://genomes.rockefeller.edu/~clifford/display_bug.png for screenshot).

Actual Results:  Strange rectangular display artifacts in X.

Expected Results:  Normal X display

Additional info:

Any XF86Config file which enabled me to use X in any sensible display mode would
be very much appreciated at this point. I understand that there is a patch for
higher colour modes coming but at the moment I can't use X properly in any mode.
Comment 1 Raphael Clifford 2002-06-14 11:12:40 EDT
Adding the "noaccel" option (as suggested by mharris) has fixed the problem. 
Although, of course, it means I have no acceleration now :)
Comment 2 Raphael Clifford 2002-06-18 13:54:43 EDT
Following more suggestions from mharris I have tried the various XaaNo...
options (having commented out noaccel).

Option "XaaNoOffscreenPixmaps"

in the "Device" Section fixes the problem.

No other single XaaNo... options seem to fix it.

This gives me a basically perfectly working system in 8bpp.
Comment 3 Mike A. Harris 2002-12-15 03:48:04 EST
Please file attach your X server config file and log file, as well
as the output of "lspci -vvn" and "lspci -vv"
Comment 4 Mike A. Harris 2003-01-02 02:34:15 EST
Without the information requested above, I can't troubleshoot this further,
nor fix the driver.  The problem will persist, and be in future releases,
and all users experiencing this problem will have to hack in the workaround
described above.

With the config file and log file however, I can work a fix/workaround
directly into the driver making this problem essentially go away for all
users.
Comment 5 Mike A. Harris 2003-01-15 14:42:36 EST
Assuming problem is resolved in Red Hat Linux 8.0 or rawhide in the
new i810 driver and closing.
Comment 6 Raphael Clifford 2003-01-21 08:08:22 EST
I no longer own the laptop so I have passed a message on to the new owner to
wait for a reply.
Raphael
Comment 7 Raphael Clifford 2003-01-21 17:49:56 EST
Created attachment 89494 [details]
The restults of running lspci -vv

These are the lspci -vv results requested
Comment 8 Raphael Clifford 2003-01-21 17:50:54 EST
Created attachment 89495 [details]
lspci -vvn results

These are results of running lspci -vvn as requested
Comment 9 Raphael Clifford 2003-01-22 07:04:06 EST
Created attachment 89513 [details]
X server log

The X server log that was requested
Comment 10 Raphael Clifford 2003-01-22 07:05:42 EST
Created attachment 89514 [details]
X config file

The X server config file that was requested
Comment 11 Raphael Clifford 2003-01-22 07:08:47 EST
Hopefull these attachments contain all the info needed.  If you need anything
else please ask.  I have reconfigured bugzilla so it has the right email address
for me now.
Raphael
Comment 12 Mike A. Harris 2003-01-24 02:17:36 EST
Fixed in our latest beta release (phoebe), and rawhide.

Note You need to log in before you can comment on or make changes to this bug.