Bug 66697 - mouse over destop icon leaves detritus all over screen
mouse over destop icon leaves detritus all over screen
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
Aaron Brown
:
Depends On:
Blocks: 67218 79579
  Show dependency treegraph
 
Reported: 2002-06-13 14:57 EDT by ellson
Modified: 2007-04-18 12:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-19 06:56:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fixed version of /etc/XF86Config-4 (1.87 KB, text/plain)
2002-07-26 11:31 EDT, ellson
no flags Details
/etc/X11/XF86Config (2.07 KB, text/plain)
2002-11-25 19:52 EST, ellson
no flags Details
/var/log/XFree86.0.log (46.97 KB, text/plain)
2002-11-25 19:53 EST, ellson
no flags Details

  None (edit)
Description ellson 2002-06-13 14:57:39 EDT
Description of Problem:
Moving the mouse over the "ellson's home" desktop icon, without clicking,
results in "ellson's home" being written all over various windows
on the screen.  It looks like perhaps an attempt to refresh or highlight
the icon text is being written to the wrong screen coordinates.

Version-Release number of selected component (if applicable):
nautilus-1.1.19-4
rawhide-release-20020613-1

How Reproducible:
every time

Steps to Reproduce:
1.move mouse over nautilus icons 
2. 
3. 

Actual Results:
string detritus

Expected Results:
no detritus

Additional Information:
I don't know that this is significant, but I'm using a dual headed display
Comment 1 Havoc Pennington 2002-06-13 15:56:24 EDT
This sounds very much like an X server bug. You may want to provide information
about your video hardware.
Comment 2 ellson 2002-06-14 10:07:32 EDT
Display hardware is Matrox G450

Processor is dual SMP:  i686 Pentium II (Deschutes) @ 450 MHz

X is XFree86-4.2.0-50.16

Problem seems to be triggered by something in Nautilus only.  Problem
occurs both with icons on desktop and with icons in nautilus window.
Comment 3 ellson 2002-07-08 09:57:11 EDT
Tentatively, I'm no longer seeing this problem on
rawhide-release-20020706-1
Any idea what fixed it?
Comment 4 ellson 2002-07-08 11:28:55 EDT
Bad news, its not completely fixed, although it does seem to be much better.

I'll play with it some more to see if I can find a way to reliably reproduce the
problem.
Comment 5 ellson 2002-07-09 18:48:39 EDT
I can create the detritus quite reliably by opening xosview on screen0 of 
the dual head display, then grabbing a gnome-terminal window and moving it 
around the screen, and in particular movie it so that it obscures
and reexposes the nautilus desktop icons.

There is continuous activity on xosview, so my guess is thats its related to 
upadates in multiple windows at the same time.

The detritus is usually the icon labels rendered in black at random positions
over the screen, but I've also seen other text droppings, not all of them from
nautilus.

This is all with today's rawhide updates:
rawhide-release-20020709-1
XFree86-4.2.0-52.01
Comment 6 Mike A. Harris 2002-07-26 03:31:50 EDT
This almost certainly is either a bug in the Matrox driver's 2D acceleration
code, or the hardware mouse pointer code.

Can you try using Option "swcursor" in your X config, and report back if
the problem goes away.  If not, try Option "noaccel" instead.  Then try
both of them at once.  Report back what if anything makes the problem
go away, and we can then work on pinpointing where the corruption occurs.
Comment 7 ellson 2002-07-26 11:29:59 EDT
Option "swcursor"                no fix.
Option "noaccel"                  fixed.
Option "noaccel" and :swcursor"   fixed. 

I played with the Xaa options.....

Option "XaaNoScreenToScreenCopy" by itself, just on Screen-0, fixed the problem.

Should I be taking up this problem with Matrox at this point?
Comment 8 ellson 2002-07-26 11:31:57 EDT
Created attachment 67224 [details]
fixed version of /etc/XF86Config-4
Comment 9 Mike A. Harris 2002-08-05 20:17:59 EDT
Yes, this problem should be brought to the attention of Matrox if
possible.  They maintain the mga driver for the most part now.  The
specs are not available for the G450, however it might still be able
to debug/troubleshoot the problem and fix it.

For now, I've added the above option to the G450 configuration by
default until a proper fix can be found.

The latest hwdata package in rawhide has this change now.  hwdata-0.37-1
Comment 10 Mike A. Harris 2002-11-07 16:26:48 EST
Reopening bug, to track for real fix rather than workaround above.
Comment 11 ellson 2002-11-18 15:14:57 EST
This problem has gotten much worse with XFree86-4.2.99.2-0.20021110.3 from
rawhide.   Now the transparent cursor is left splatted all over Screen-1.
This is the other screen from the first problem and the new splats are not fixed
by 'Option      "XaaNoScreenToScreenCopy" ""'
Comment 12 Mike A. Harris 2002-11-25 09:44:15 EST
In order to try and find the best fix, I will need you to test-drive
some different drivers for me.

ftp://people.redhat.com/mharris/test-drivers/mga_drv.o

Please copy this overtop of the existing mga_drv.o that comes with
the rawhide XFree86 you're using now.

Edit the config file, and comment out all XaaNo options, noaccel, etc.

We want to test this driver with no special options enabled.

Please provide me with an updated comment, as well as the output of:
ls -al /usr/X11R6/lib/modules/drivers/mga_drv.o

and a new copy of your X log and config file
Comment 13 ellson 2002-11-25 19:52:55 EST
Created attachment 86424 [details]
/etc/X11/XF86Config
Comment 14 ellson 2002-11-25 19:53:49 EST
Created attachment 86425 [details]
/var/log/XFree86.0.log
Comment 15 ellson 2002-11-25 19:55:57 EST
Looks good so far.   I've not seen any text detritus nor cursor splats
after about 1 hour of usage.

ellson@amber:ellson> ls -al /usr/X11R6/lib/modules/drivers/mga_drv.o
-rw-r--r--    1 root     root       189974 Nov 25 19:32
/usr/X11R6/lib/modules/drivers/mga_drv.o
Comment 16 Mike A. Harris 2002-12-19 06:56:44 EST
Great, closing as fixed in rawhide with Xrender patch

Note You need to log in before you can comment on or make changes to this bug.