Bug 667032 - RFE: Update to version 0.8
RFE: Update to version 0.8
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: shotwell (Show other bugs)
rawhide
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
: 667369 (view as bug list)
Depends On: 661024 667490
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-04 01:27 EST by Jeff Raber
Modified: 2011-01-25 15:31 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-25 15:31:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jeff Raber 2011-01-04 01:27:45 EST
Below is copied directly from http://www.yorba.org/blog/jim/2010/12/shotwell-080-and-gexiv2-022-released.html

Yorba has released Shotwell 0.8.0, an update to our digital photo organizer.  This release includes some great new features:

   * Video support for most major video formats, including importing them off of camera and adding them to events and tags.

  * Publish videos to major Web services, including YouTube, Flickr, Facebook, and PicasaWeb.

  * Runtime monitoring of library directory and auto-import of newly created files.

  * Background writing of metadata (tags, titles, ratings, orientation, and exposure date) to master files (user-configurable).

  * Flagging photos for batch operations.

  * Set multiple photos to desktop background slideshow.

  * Numerous translation updates.

  * Various bug fixes.

It's highly recommended all users upgrade.

In addition, Yorba has released an update to our Exiv2 GObject wrapper library, gexiv2 0.2.2.  (This library is a requirement for Shotwell.)  This update fixes a bug where a photo file with malformed EXIF could cause a crash.  It's highly recommended that all users upgrade.

Download a source tarball from the Shotwell home page at:
http://www.yorba.org/shotwell/

Download a source tarball from the gexiv2 home page at:
http://trac.yorba.org/wiki/gexiv2

Binaries for Ubuntu Lucid (gexiv2) and Maverick (Shotwell, gexiv2) are available at Yorba's Launchpad PPA:
https://launchpad.net/~yorba/+archive/ppa
Comment 1 Siddhesh Poyarekar 2011-01-04 01:36:41 EST
shotwell builds have been failing in rawhide due to the vala upgrade to 0.11.
Comment 2 Siddhesh Poyarekar 2011-01-05 08:11:19 EST
*** Bug 667369 has been marked as a duplicate of this bug. ***
Comment 3 Siddhesh Poyarekar 2011-01-05 13:54:13 EST
Adding the vala bug report to dependency. We can't build shotwell 0.8.0 without that bug getting fixed.
Comment 4 Siddhesh Poyarekar 2011-01-05 13:55:29 EST
We also need libgexiv2 0.22 to be able to finish this build.
Comment 5 Matěj Cepl 2011-01-06 19:13:33 EST
(In reply to comment #4)
> We also need libgexiv2 0.22 to be able to finish this build.

What's http://koji.fedoraproject.org/koji/buildinfo?buildID=212189 ???
Comment 6 Matthias Clasen 2011-01-25 15:31:43 EST
0.8.1 is in rawhide

Note You need to log in before you can comment on or make changes to this bug.