Bug 66707 - python2 should include Makefile
python2 should include Makefile
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: python2 (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-13 17:37 EDT by Michael Stenner
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-13 17:37:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Stenner 2002-06-13 17:37:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i686; U;) Gecko/20020509

Description of problem:
The python standard module packaging system, distutils, requires that the python
Makefile be present on the system.  You include the makefile in python2-devel
rather than in python2.  This prevents users from installing python modules
distributed that way.  (Especially nasty since distutils provides a convenient
"install this in my homedir" option that's great for non-root folks.)

They python people consider the Makefile an essential part of a python distribution.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. run "python2 setup.py install" on a box without python2-devel
2. watch error happen
3. slap forehead

If you want a module to test with, although that's bordering on silly, use
http://www.dulug.duke.edu/~mstenner/software/logger/
	

Additional info:

elmo$ python2 setup.py install 
running install
Traceback (most recent call last):
  File "setup.py", line 12, in ?
    py_modules=["logger"])
  File "/tmp/32444-i386/install/usr/lib/python2.1/distutils/core.py", line 138,
in setup
  File "/tmp/32444-i386/install/usr/lib/python2.1/distutils/dist.py", line 899,
in run_commands
  File "/tmp/32444-i386/install/usr/lib/python2.1/distutils/dist.py", line 918,
in run_command
  File "/usr/lib/python2.1/cmd.py", line 112, in ensure_finalized
    return self.default(line)
  File "/tmp/32444-i386/install/usr/lib/python2.1/distutils/command/install.py",
line 256, in finalize_options
  File "/tmp/32444-i386/install/usr/lib/python2.1/distutils/sysconfig.py", line
370, in get_config_vars
  File "/tmp/32444-i386/install/usr/lib/python2.1/distutils/sysconfig.py", line
302, in _init_posix
distutils.errors.DistutilsPlatformError: invalid Python installation: unable to
open /usr/lib/python2.1/config/Makefile (No such file or directory)
Comment 1 Trond Eivind Glomsrxd 2002-06-14 18:07:52 EDT
It's in python-devel, which you'll need for installing those modules.

Note You need to log in before you can comment on or make changes to this bug.