Bug 667124 - artifacts visible on scroll
artifacts visible on scroll
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
14
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-04 09:37 EST by Pádraig Brady
Modified: 2011-01-10 03:51 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-07 07:47:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
See the area enclosed in red (145.33 KB, image/png)
2011-01-04 09:41 EST, Pádraig Brady
no flags Details

  None (edit)
Description Pádraig Brady 2011-01-04 09:37:36 EST
See the attached screenshot taken with:
import -display :0.0 -window root ff-artifacts.png

The area circled in red has artifacts due to the overlying terminal window.
They appear after scrolling the firefox content.
This happens with general.smoothScroll on or off.

$ rpm -q xorg-x11-drv-intel xorg-x11-server-Xorg kernel firefox
xorg-x11-drv-intel-2.12.0-6.fc14.1.i686
xorg-x11-server-Xorg-1.9.3-3.fc14.i686
kernel-2.6.35.10-72.fc14.i686
firefox-3.6.13-1.fc14.i686
Comment 1 Pádraig Brady 2011-01-04 09:41:28 EST
Created attachment 471679 [details]
See the area enclosed in red
Comment 2 Pádraig Brady 2011-01-04 09:45:14 EST
I should also add:

$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)

Also I don't see the issue in other apps,
but I do see flickering in the problematic
area in other apps, but they do always draw
in a consistent state, when you stop scrolling.

Also it doesn't happen immediately, but may
take 10-20s of scrolling in firefox to show the issue
Comment 3 Martin Stransky 2011-01-07 07:46:46 EST
This one is a firefox bug fixed in rawhide.
Comment 4 Pádraig Brady 2011-01-07 11:28:30 EST
Cool thanks.
Will it be backported. It's a minor issue so I guess not.
Do you have a pointer to the bug or patch for the issue?
Comment 5 Martin Stransky 2011-01-10 03:51:36 EST
It's fixed by new layer engine in ff4 and it's not going to be backported to 3.6 line.

Note You need to log in before you can comment on or make changes to this bug.