Bug 66717 - Multiple sessions from different displays confuses dcop/klauncher
Multiple sessions from different displays confuses dcop/klauncher
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-14 05:54 EDT by ville.sulko
Modified: 2007-04-18 12:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-22 13:40:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ville.sulko 2002-06-14 05:54:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; Q312461)

Description of problem:
Starting another KDE session from another X-terminal confuses KDE on the 
previous sessions from different X-terminals. Results in 'KLaucher could not be 
reached via DCOP' -message.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start a KDE session for user nnn from console
2. Start another KDE session for user nnn from a remote X-terminal
3. Try to start an application (say, a konsole window) from console session 
(the first session)
	

Actual Results:  Error message 'KLaucher could not be reached via DCOP', and 
possibly later another message 'There was an error setting up inter-process 
communications for KDE. The message returned by the system was: Could not open 
network socket. Please check that the "dcopserver" program is running'.
The second session works as expected (actually, seems like the last session 
started always works, the other don't).

Expected Results:  Applications start up as expected.

Additional info:
Comment 1 Rex Dieter 2002-06-14 09:32:20 EDT
In my experience, this is simply a KDE limitation (1 KDE sesion per user per 
machine), and has been there since the 2.x days.  You CAN have multiple 
sessions on the same machine for different users and/or have multiple sessions 
for the same user on difference machines.
Comment 2 ville.sulko 2003-04-15 09:46:55 EDT
Just upgraded to RH9, and found out the same problem is still there...
Did some googling, and found :

http://bugs.kde.org/show_bug.cgi?id=40153

So, it seems this is a RedHat -specific bug... Modified /usr/bin/startkde 
incorrectly deletes all socket-files used by other dcop processes, thus making 
it impossible for existing sessions to communicate with the dcop process...
Commenting out the following lines helps :

rm -f ~/.DCOPserver-`/bin/hostname`_$DISPLAY
for i in /tmp/.ICE-unix/* /tmp/.ICE-unix/.*; do
      [ -O $i ] && rm -f $i
done

Note that I also commented out the first "rm" (wasn't commented in the kde 
bugreport). This is because /bin/hostname always returns X client hostname, not 
the display (X server) name. And in my opinion, what we want to delete is the 
file that refers to the display we're using...

So, if old (killed/died) session cleanup is needed, more checks are required. 
For now i'm happy to leave some orphan files behind...
Comment 3 Rex Dieter 2005-06-22 12:55:18 EDT
This can probably be closed, as I'm pretty sure this has been fixed in
development for some time.
Comment 4 Ngo Than 2005-06-22 13:40:28 EDT
it's fixed in current fedora

Note You need to log in before you can comment on or make changes to this bug.