Bug 667175 - libQtWebKit.so has no debug info
libQtWebKit.so has no debug info
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
14
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-04 13:24 EST by Jan Kratochvil
Modified: 2011-04-20 15:22 EDT (History)
10 users (show)

See Also:
Fixed In Version: phonon-4.5.0-2.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-20 15:22:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kratochvil 2011-01-04 13:24:40 EST
Description of problem:
One cannot debug libQtWebKit.

Version-Release number of selected component (if applicable):
qt-debuginfo-4.7.1-7.fc14.x86_64

How reproducible:
Always.

Steps to Reproduce:
gdb /usr/lib64/libQtWebKit.so.4.7.1
+
(gdb) list JSClassCreate

Actual results:
warning: "/usr/lib/debug/usr/lib64/libQtWebKit.so.4.7.1.debug": separate debug info file has no debug info
+
No symbol table is loaded.  Use the "file" command.

Expected results:
no warning
+
listed source file for JSClassCreate

Additional info:
There was an advice on #gdb@freenode:
andre: dan2: he'd has to add -webkit-debug to the ./configure line
Comment 1 Rex Dieter 2011-01-04 16:31:07 EST
qt's configure has no such -webkit-debug option that I can tell.
Comment 2 Rex Dieter 2011-02-23 15:45:27 EST
Looks like support was added after 4.7.1 release.  We found this commit,

http://qt.gitorious.org/qt/qt/commit/9e5a1b618ea7bf579c7b2d66a8844d606405bc6d
Comment 3 Rex Dieter 2011-02-23 15:49:56 EST
%changelog
* Wed Feb 23 2011 Rex Dieter <rdieter@fedoraproject.org> 1:4.7.1-18
- libQtWebKit.so has no debug info (#667175)

Let's see how the build goes,
http://koji.fedoraproject.org/koji/taskinfo?taskID=2861807
Comment 4 Jan Kratochvil 2011-02-23 20:12:43 EST
It works now, thanks.

(gdb) list JSClassCreate
51	#include "RegExpConstructor.h"
52	
53	using namespace JSC;
54	
55	JSClassRef JSClassCreate(const JSClassDefinition* definition)
56	{
57	    initializeThreading();
58	    RefPtr<OpaqueJSClass> jsClass = (definition->attributes & kJSClassAttributeNoAutomaticPrototype)
59	        ? OpaqueJSClass::createNoAutomaticPrototype(definition)
60	        : OpaqueJSClass::create(definition);
Comment 5 Rex Dieter 2011-04-01 15:10:48 EDT
nvm, qt-4.7.1-17 is still the latest in dist-f14-updates
Comment 6 Fedora Update System 2011-04-08 15:56:37 EDT
phonon-4.5.0-2.fc14,qt-4.7.2-8.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/phonon-4.5.0-2.fc14,qt-4.7.2-8.fc14
Comment 7 Fedora Update System 2011-04-13 16:48:20 EDT
Package phonon-4.5.0-2.fc14, qt-4.7.2-8.fc14, phonon-backend-gstreamer-4.5.0-1.fc14:
* should fix your issue,
* was pushed to the Fedora 14 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing phonon-4.5.0-2.fc14 qt-4.7.2-8.fc14 phonon-backend-gstreamer-4.5.0-1.fc14'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/phonon-backend-gstreamer-4.5.0-1.fc14,phonon-4.5.0-2.fc14,qt-4.7.2-8.fc14
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2011-04-20 15:21:59 EDT
phonon-4.5.0-2.fc14, qt-4.7.2-8.fc14, phonon-backend-gstreamer-4.5.0-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.