Bug 667219 - Connection problems using kerberos against EMC Celerra servers
Summary: Connection problems using kerberos against EMC Celerra servers
Keywords:
Status: CLOSED DUPLICATE of bug 645127
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: cifs-utils
Version: 6.0
Hardware: Unspecified
OS: Other
low
medium
Target Milestone: rc
: ---
Assignee: Jeff Layton
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-01-04 20:25 UTC by Stefan Walter
Modified: 2014-06-18 07:40 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-01-04 22:02:30 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Stefan Walter 2011-01-04 20:25:36 UTC
Description of problem:

Attempting to mount a share from an EMC Celerra using kerberos authentication
with hmac_md5 fails at our site. Sniffing on the network shows that the
NAS returns RPC_NT_INVALID_BINDING even though tickets could successfully
be obtained by cifs.upcall. Password-based authentication works when
'sec=krb5' is removed from the mount options.

It seems that the bug that we are running into is this recently discovered
problem in cifs-utils:

http://www.mail-archive.com/linux-cifs@vger.kernel.org/msg02167.html

Could you please apply these patches to the cifs-utils of RHEL6?


Version-Release number of selected component (if applicable):

RHEL6 workstation, up2date.


How reproducible:

Configure krb5.conf to only use hmac_md5 (or use an 2008R2 AD server without
backward compatibility for weak crypto). 

Steps to Reproduce:

1. Get a ticket as the user used for authentication (someuser)
2. Run mount.cifs as root with arguments like this:

mount.cifs -o user=someuser,uid=33333,gid=33333,sec=krb5 //server/share /mnt
  

Actual results:

mount error(5): Input/output error


Expected results:

Should mount the share.

Comment 2 Jeff Layton 2011-01-04 22:02:30 UTC

*** This bug has been marked as a duplicate of bug 645127 ***


Note You need to log in before you can comment on or make changes to this bug.