Bug 667294 - libboost_unit_test_framework-mt.so.debug has no debug info
Summary: libboost_unit_test_framework-mt.so.debug has no debug info
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: boost
Version: 14
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ---
Assignee: Benjamin Kosnik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
: 697328 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-01-05 06:12 UTC by Jan Kratochvil
Modified: 2013-08-09 05:50 UTC (History)
7 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2011-04-18 21:20:55 UTC


Attachments (Terms of Use)

Description Jan Kratochvil 2011-01-05 06:12:19 UTC
Description of problem:
#gdb@freenode.net:
GungaDin: I have the following problem: for some reason, gdb doesn't step into a lot of code that's inside header (hpp) or ipp files. 'step' just ends up as 'next' in these cases... any ideas?
GungaDin: It happens on Fedora 14.

Version-Release number of selected component (if applicable):
boost-debuginfo-1.44.0-4.fc14.x86_64

How reproducible:
Always.

Steps to Reproduce:
gdb /usr/lib64/libboost_unit_test_framework-mt.so.1.44.0

Actual results:
warning: "/usr/lib/debug/usr/lib64/libboost_unit_test_framework-mt.so.1.44.0.debug": separate debug info file has no debug info

Expected results:
no warning
.debug_* sections.

Additional info:
.spec uses "RelWithDebInfo", I do not see why it does not work.

Comment 1 Petr Machata 2011-01-06 14:07:32 UTC
I suspect that the following line is the culprit here:
         -DCMAKE_CXX_FLAGS=-DBOOST_IOSTREAMS_USE_DEPRECATED \

I haven't checked yet, but I'm afraid that that will override the flags, not augment them.  All the MPI-enabled libraries are built with debuginfo as they should.

Comment 2 Fedora Update System 2011-01-06 16:42:18 UTC
boost-1.44.0-6.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/boost-1.44.0-6.fc14

Comment 3 Fedora Update System 2011-01-07 20:02:05 UTC
boost-1.44.0-6.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update boost'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/boost-1.44.0-6.fc14

Comment 4 Fedora Update System 2011-01-10 23:11:54 UTC
boost-1.44.0-7.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/boost-1.44.0-7.fc14

Comment 5 Fedora Update System 2011-01-18 21:38:44 UTC
boost-1.44.0-7.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Tim Niemueller 2011-04-01 06:55:40 UTC
This reintroduces bug #654480. Pleas re-verify.

Comment 7 Tim Niemueller 2011-04-01 07:18:32 UTC
To be a little more precise (sorry, currently at RoboCup):

# rpm -q boost
boost-1.44.0-7.fc14.x86_64

# nm /usr/lib/debug/usr/lib64/libboost_iostreams-mt.so.1.44.0.debug  | grep file_descriptor_source
000000000000e310 T _ZN5boost9iostreams22file_descriptor_source4openEPKcSt13_Ios_Openmode
000000000000e290 T _ZN5boost9iostreams22file_descriptor_source4openERKNS0_6detail4pathESt13_Ios_Openmode
000000000000e410 T _ZN5boost9iostreams22file_descriptor_source4openERKSsSt13_Ios_Openmode
000000000000ddf0 T _ZN5boost9iostreams22file_descriptor_source4openEiNS0_21file_descriptor_flagsE
000000000000ea10 T _ZN5boost9iostreams22file_descriptor_sourceC1EPKcSt13_Ios_Openmode
000000000000ce00 T _ZN5boost9iostreams22file_descriptor_sourceC1ERKS1_
000000000000ea70 T _ZN5boost9iostreams22file_descriptor_sourceC1ERKSsSt13_Ios_Openmode
000000000000e8f0 T _ZN5boost9iostreams22file_descriptor_sourceC1EiNS0_21file_descriptor_flagsE
000000000000ea10 T _ZN5boost9iostreams22file_descriptor_sourceC2EPKcSt13_Ios_Openmode
000000000000ce00 T _ZN5boost9iostreams22file_descriptor_sourceC2ERKS1_
000000000000ea70 T _ZN5boost9iostreams22file_descriptor_sourceC2ERKSsSt13_Ios_Openmode
000000000000e8f0 T _ZN5boost9iostreams22file_descriptor_sourceC2EiNS0_21file_descriptor_flagsE

There should be the symbol _ZN5boost9iostreams22file_descriptor_sourceC1Eib, but it isn't. It seems the deprecated functions are not built into Boost anymore. Can you please have a look? Thanks!

Comment 8 Petr Machata 2011-04-04 11:27:23 UTC
The problem was, again, in passing CXXFLAGS.  Passing via CMAKE_CXX_FLAGS for some reason breaks when rpm re-quotes the expression as a result of %%{optflags} expansion.

Comment 9 Fedora Update System 2011-04-04 11:29:33 UTC
boost-1.44.0-8.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/boost-1.44.0-8.fc14

Comment 10 Fedora Update System 2011-04-05 05:20:30 UTC
Package boost-1.44.0-8.fc14:
* should fix your issue,
* was pushed to the Fedora 14 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing boost-1.44.0-8.fc14'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/boost-1.44.0-8.fc14
then log in and leave karma (feedback).

Comment 11 Fedora Update System 2011-04-18 21:20:50 UTC
boost-1.44.0-8.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Denis Arnaud 2011-04-22 14:58:37 UTC
*** Bug 697328 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.