Bug 66732 - Binaries are in /usr/X11R6/bin despite not requiring X11
Summary: Binaries are in /usr/X11R6/bin despite not requiring X11
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: transfig (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-06-14 15:20 UTC by bac
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-14 15:20:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description bac 2002-06-14 15:20:20 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux alpha; en-US; rv:1.0.0) Gecko/20020610
Debian/1.0.0-1

Description of problem:
The transfig binaries do not appear to require X11, yet are in the binary
directory for X11 programs.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Unset DISPLAY (if it is set)
2. Remove X11 directory from PATH
3. Try using (for example) fig2dev


Additional info:

This does not cause any problems by default, since /usr/X11R6/bin is in the PATH
even when X11 is not being used.  Customised environments are most likely to suffer.

Comment 1 Ngo Than 2002-06-14 18:28:49 UTC
It's fixed in transfig-3.2.3d-5


Note You need to log in before you can comment on or make changes to this bug.