Bug 66733 - export command creates CVS subdirectory
Summary: export command creates CVS subdirectory
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: cvs (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Martin Stransky
QA Contact:
URL:
Whiteboard:
Keywords:
: 130834 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-06-14 15:40 UTC by ken_laird
Modified: 2007-04-18 16:43 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-10 12:38:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description ken_laird 2002-06-14 15:40:40 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
According to the CVS documentation, the export command should just
extract files from a repository and not create a CVS subdirectory in
the local working directory.  However, version 1.11.1p1-7 does create
CVS subdirectories.  This becomes a problem if you have more than one
module that you want to export to the same local directory for packaging purposes.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Create a module in cvs and add some files.
2.cd to an empty local directory.
3.issue the command cvs export -D tomorrow <name of module>
4.list the directory created by cvs.
	

Actual Results:  a CVS subdirectory will have been created, just as if you had
used the
update or checkout command.

Expected Results:  Should have just extracted the files and not created a CVS
subdirectory.

Additional info:

Comment 1 Rick Johnson 2004-08-09 20:17:41 UTC
Bug is reproducable in Red Hat Enterprise 3 Update 2 with
cvs-1.11.2-24. Updated platform.

When exporting a module and the "-d" flag is specified to create a
source distribution, the CVS subdirs are erroniously included.
Possible problem in client.c

Probably should be updated under Enterprise Linux and all platforms.

Comment 2 Rick Johnson 2004-08-10 00:33:30 UTC
Rawhide version cvs-1.11.17-3 seems to contain a fix in client.c that
resolves this problem. Any chance this could be backported to RHEL 3?

Comment 3 Martin Stransky 2005-03-10 12:38:22 UTC
Hmm, I couldn't reproduce it with cvs-1.11.2-25 and newer. Let me
know, if you can do it and how.

Comment 4 Martin Stransky 2005-03-10 12:59:53 UTC
*** Bug 130834 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.