Bug 66748 - Kaddressbook - changes to "file as" field lost on save or exit
Kaddressbook - changes to "file as" field lost on save or exit
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Petr Rockai
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-14 16:17 EDT by Rich Peiffer
Modified: 2007-04-18 12:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 14:26:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rich Peiffer 2002-06-14 16:17:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.0.0-10; Linux)

Description of problem:
When using kaddressbook and changes are made to the "file as" field for a particular entry, the changes appear just fine on the display and it looks like the change is in place. You can go back into the entry and the changes still appear intact.  The moment the changes are saved to disk, the "file as" field for all address book entries will always resort back to  firstname lastname order, regardless of what they were set to.

In scouring the kde mailing lists it appears that the developers have already fixed this problem.

Because the new address book under KDE 3 is now integral to KMail as well, and the "file as" field is critical to how entries display in the address book, I would love to see this as a bug fix under 7.3.

I use the address book under KDE and KMail all the time and have become quite reliant on it.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Enter an entry using kaddressbook.  Enter first name, last name, and a company.
2.Select some available combination in the "file as" field" other then just firstname lastname.  For ex. companyname (lastname, firstname).
3.Exit entry edit.
4.Notice listing now shows the "file as" field as you specified.
5.Click on save icon.
6.Notice "file as" field has now changed.
 

Actual Results:  "File as" field changed, which changed the order address book entries are sorted in.

Expected Results:  "File as" field should be saved as I specified so address book entries will sort the way I want them to.

Additional info:

As stated above, I believe the bug is already fixed by the original developers, but would like to see RedHat officially release a patch for this.
Comment 1 Petr Rockai 2006-07-17 14:25:54 EDT
This bug is reported against old release of Red Hat Linux or Fedora Core 
that is no longer supported. Chances are that it has been already fixed in 
newer Fedora Core release. If you still experience the problem with 
current release of Fedora Core, please update the Version field (you may 
need to switch Product to Fedora Core first) in the bug report and put it 
back to NEW state.
Comment 2 Bill Nottingham 2006-10-18 14:26:03 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
If this issue is still present in a current Fedora Core release, please
open a new bug with the relevant information.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.