Bug 667557 - RFE: unmount root dir on shutdown
RFE: unmount root dir on shutdown
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
rawhide
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks: systemd-RFE
  Show dependency treegraph
 
Reported: 2011-01-05 18:56 EST by Lennart Poettering
Modified: 2012-03-12 22:39 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-12 22:39:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lennart Poettering 2011-01-05 18:56:28 EST
In an ideal world we'd unmount the root dir on shutdown instead of just remounting it r/o, by means of pivot_root(). The kernel currently doesn't allow us to do this properly, since the root dir stays pinned even after the pivot_root().

This is just a tracker bug, so that we keep in mind that we'd love to do this properly one day, when the kernel is nicer to us.
Comment 1 Fedora Admin XMLRPC Client 2011-10-20 12:26:14 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Jóhann B. Guðmundsson 2012-02-27 06:17:25 EST
Now year has passed any changes been made to satisfy this? 

Btw you probably should just move this to TODO list and close this RFE...
Comment 3 Lennart Poettering 2012-03-12 22:39:15 EDT
This is actually implemented since a while for F17. Closing.

Note You need to log in before you can comment on or make changes to this bug.