Bug 667571 - Did something change my CUPS driver from Postscript to pxlmono?
Summary: Did something change my CUPS driver from Postscript to pxlmono?
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-printer
Version: 14
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-01-06 02:03 UTC by D. Wagner
Modified: 2011-03-15 21:56 UTC (History)
3 users (show)

Fixed In Version: system-config-printer-1.2.7-2.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-02-07 20:01:05 UTC


Attachments (Terms of Use)
Output from lpinfo -l -v, with the problematic configuration (1.76 KB, text/plain)
2011-01-06 21:10 UTC, D. Wagner
no flags Details
Output from lpinfo -l -v, after I fixed the configuration by changing the driver to Postscript (1.76 KB, text/plain)
2011-01-06 21:10 UTC, D. Wagner
no flags Details
My PPD (/etc/cups/ppd/hp1200.ppd), in the problematic configuration, before I fixed it manually by switching to Postscript driver (20.96 KB, application/vnd.cups-ppd)
2011-01-06 21:11 UTC, D. Wagner
no flags Details
My PPD (/etc/cups/ppd/hp1200.ppd), after I fixed the configuration by switching to Postscript driver (104.89 KB, application/vnd.cups-ppd)
2011-01-06 21:12 UTC, D. Wagner
no flags Details
Advanced diagnostic output from the graphical troubleshooter, after fixing the configuration manually by switching to Postscript (191.65 KB, text/plain)
2011-01-06 21:12 UTC, D. Wagner
no flags Details
Error log from graphical troubleshooter, after I fixed my configuration manually by switching to Postscript driver (129.38 KB, text/plain)
2011-01-06 21:13 UTC, D. Wagner
no flags Details

Description D. Wagner 2011-01-06 02:03:48 UTC
Description of problem:

I have a HP 1200 printer.  Printing to it used to be fairly fast.  Now when I try to print a web page, it is very slow: it takes forever to print anything, even a single-page web page.   The green LED on the printer just blinks, and the job sits in the queue  for a long time, before anything comes out of the printer -- we're talking, like, hours in some cases.  (It's hard to pinpoint when the change occurred.)

Based upon a recent post to the fedora-users mailing list [1], I've formed a hypothesis about the cause of this.  I'm guessing something may have changed my printer driver from HP LaserJet 1200 Postscript (from memory) to HP LaserJet 1200 Foomatic/pxlmono.  (I think, though I'm certain, that I was previously using the Postscript driver, though I'm not certain whether it was Postscript or Foomatic/Postscript, nor am I sure whether I was using the HP LaserJet 1200 or LaserJet 1200n profile previously.)  Open Printing recommends pxlmono to make graphics print faster [2].

I've confirmed that switching the driver from Foomatic/pxlmono over to Postscript seems to make the printer work again: web pages print fast, so far.  I haven't done extensive testing with the new Postscript driver yet.

I have a HP LaserJet 1200n (networked by Ethernet; not connected by USB).

The fedora-users mailing list post was from another user who also seems to have experienced the same problem, and who attributed it to upgrading from Fedora 13 to Fedora 14.


[1] http://lists.fedoraproject.org/pipermail/users/2011-January/389799.html
[2] http://www.openprinting.org/printer/HP/HP-LaserJet_1200

Version-Release number of selected component (if applicable):

hplip-3.10.9-5.fc14.x86_64
hplip-libs-3.10.9-5.fc14.x86_64
hpijs-3.10.9-5.fc14.x86_64
cups-1.4.4-11.fc14.x86_64
cups-libs-1.4.4-11.fc14.x86_64
cups-libs-1.4.4-11.fc14.i686
cups-pdf-2.5.0-4.fc14.x86_64
ghostscript-cups-8.71-16.fc14.x86_64

Comment 1 D. Wagner 2011-01-06 04:03:51 UTC
It's possible that this might be a duplicate of bug #661814.

Here are some more RPM versions on my system, if relevant:

foomatic-4.0.5-1.fc14.x86_64
system-config-printer-1.2.5-8.fc14.x86_64

Comment 2 Tim Waugh 2011-01-06 09:31:39 UTC
The only reasons PPDs in an existing system would be changed are:

* hpijs has been updated, and an existing PPD has ", hpcups" in its NickName attribute, and it doesn't have an hpPrinterLanguage attribute (i.e. it was generated using an older version of hpcups)

* gutenprint-cups has been updated, and an existing PPD has a line starting with "*%Gutenprint Filename:", or has one of the attributes StpPPDLocation, StpDriverName, or StpLocale.

We shouldn't be changing other PPDs in other situations. (Arguably, we could change foomatic PPDs -- Ubuntu does this -- but I am not in favour of changing existing PPDs unless absolutely necessary.)

So let's leave bug #661814 as tracking "wrong default driver for this printer", and this bug can track "existing PPD is changed unexpectedly".

I guess we need to try installing Fedora 13, setting up some queues, upgrading to Fedora 14 and verifying what driver they are now using.

Comment 4 D. Wagner 2011-01-06 21:09:19 UTC
OK.  Unfortunately I can't guarantee that I'm remembering my prior CUPS configuration correctly, so this is a low-reliability bug report.  If it looks like the code wouldn't change the CUPS driver, it's very possible my memory is mistaken.  Sorry for the poor quality bug report.

lpinfo -l -v shows nothing that looks useful to me.  I'll attach the output of lpinfo -l -v both before and after changing to Postscript driver (before = pxlmono = very slow printing = what it was before I manually intervened yesterday, after = Postscript = after I manually changed the driver to Postscript).  I'll also attach the PPD before and after.  And I'll attach some output from the graphical troubleshooter (System >> Administration >> Printing >> Help >> Troubleshoot), which I ran only after changing to Postscript (I don't have this from before I made the change).

If you're looking for a Device ID, the following commands gave me more promising output:

# /usr/lib/cups/backend/snmp 192.0.0.192
network socket://192.0.0.192 "HP LaserJet 1200" "HP LaserJet 1200" "MFG:Hewlett-Packard;CMD:PJL,MLC,PCL,PCLXL,POSTSCRIPT;MDL:HP LaserJet 1200;CLS:PRINTER;DES:Hewlett-Packard LaserJet 1200;MEM:16MB" ""
# /usr/lib/cups/backend/socket            
network socket "Unknown" "AppSocket/HP JetDirect"

This is a HP LaserJet 1200 printer attached to a HP JetDirect device that provides Ethernet connectivity, and then connected by Ethernet.

Comment 5 D. Wagner 2011-01-06 21:10:04 UTC
Created attachment 472131 [details]
Output from lpinfo -l -v, with the problematic configuration

Comment 6 D. Wagner 2011-01-06 21:10:36 UTC
Created attachment 472132 [details]
Output from lpinfo -l -v, after I fixed the configuration by changing the driver to Postscript

Comment 7 D. Wagner 2011-01-06 21:11:26 UTC
Created attachment 472133 [details]
My PPD (/etc/cups/ppd/hp1200.ppd), in the problematic configuration, before I fixed it manually by switching to Postscript driver

Comment 8 D. Wagner 2011-01-06 21:12:06 UTC
Created attachment 472134 [details]
My PPD (/etc/cups/ppd/hp1200.ppd), after I fixed the configuration by switching to Postscript driver

Comment 9 D. Wagner 2011-01-06 21:12:48 UTC
Created attachment 472135 [details]
Advanced diagnostic output from the graphical troubleshooter, after fixing the configuration manually by switching to Postscript

Comment 10 D. Wagner 2011-01-06 21:13:23 UTC
Created attachment 472136 [details]
Error log from graphical troubleshooter, after I fixed my configuration manually by switching to Postscript driver

Comment 12 Joachim Backes 2011-01-17 08:29:43 UTC
(In reply to comment #0)
> Description of problem:
> 
> I have a HP 1200 printer.  Printing to it used to be fairly fast.  Now when I
> try to print a web page, it is very slow: it takes forever to print anything,
> even a single-page web page.   The green LED on the printer just blinks, and
> the job sits in the queue  for a long time, before anything comes out of the
> printer -- we're talking, like, hours in some cases.  (It's hard to pinpoint
> when the change occurred.)

Having similar problems with a Lexmark e120n network printer (see https://bugzilla.redhat.com/show_bug.cgi?id=670089)

> 
> Based upon a recent post to the fedora-users mailing list [1], I've formed a
> hypothesis about the cause of this.  I'm guessing something may have changed my
> printer driver from HP LaserJet 1200 Postscript (from memory) to HP LaserJet
> 1200 Foomatic/pxlmono.  (I think, though I'm certain, that I was previously
> using the Postscript driver, though I'm not certain whether it was Postscript
> or Foomatic/Postscript, nor am I sure whether I was using the HP LaserJet 1200
> or LaserJet 1200n profile previously.)  Open Printing recommends pxlmono to
> make graphics print faster [2].
> 
> I've confirmed that switching the driver from Foomatic/pxlmono over to
> Postscript seems to make the printer work again: web pages print fast, so far. 
> I haven't done extensive testing with the new Postscript driver yet.
> 
> I have a HP LaserJet 1200n (networked by Ethernet; not connected by USB).
> 
> The fedora-users mailing list post was from another user who also seems to have
> experienced the same problem, and who attributed it to upgrading from Fedora 13
> to Fedora 14.
> 
> 
> [1] http://lists.fedoraproject.org/pipermail/users/2011-January/389799.html
> [2] http://www.openprinting.org/printer/HP/HP-LaserJet_1200
> 
> Version-Release number of selected component (if applicable):
> 
> hplip-3.10.9-5.fc14.x86_64
> hplip-libs-3.10.9-5.fc14.x86_64
> hpijs-3.10.9-5.fc14.x86_64
> cups-1.4.4-11.fc14.x86_64
> cups-libs-1.4.4-11.fc14.x86_64
> cups-libs-1.4.4-11.fc14.i686
> cups-pdf-2.5.0-4.fc14.x86_64
> ghostscript-cups-8.71-16.fc14.x86_64

Comment 13 Tim Waugh 2011-01-17 11:57:35 UTC
This bug report is for tracking the suggestion that a queue's driver is changed on upgrade.

For the bug report about the pxlmono driver being slow see bug #661814.

Summary updated to reflect that.

Comment 14 Fedora Update System 2011-01-21 13:26:28 UTC
system-config-printer-1.2.6-3.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/system-config-printer-1.2.6-3.fc14

Comment 15 Fedora Update System 2011-01-21 13:26:43 UTC
system-config-printer-1.2.6-3.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/system-config-printer-1.2.6-3.fc13

Comment 16 Fedora Update System 2011-01-21 23:00:35 UTC
system-config-printer-1.2.6-3.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-printer'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/system-config-printer-1.2.6-3.fc13

Comment 17 Tim Waugh 2011-01-24 12:33:54 UTC
There are two things that might explain this:

1. the foomatic-db recommended driver may have changed, after which you may have recreated the queue using the same procedure as before.  This would result in a different driver being used.

2. there was a bug in system-config-printer that would cause a different driver to be used than the one selected.

Comment 18 Fedora Update System 2011-02-07 20:00:12 UTC
system-config-printer-1.2.6-3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 19 Joachim Backes 2011-02-08 06:45:09 UTC
(In reply to comment #18)
> system-config-printer-1.2.6-3.fc14 has been pushed to the Fedora 14 stable
> repository.  If problems still persist, please make note of it in this bug
> report.

Still having the problem described in BZ 670089, even with system-config-printer-1.2.6-3.fc14. Trying to print "http://www.rhrk.uni-kl.de" on my lexmark network printer, nothing is printed, and the printer icon remains in the notification area for a lot of minutes, and the network is busy. By changing the driver from pxlmono to ljet4, I get rid of this problem.

Comment 20 Jiri Popelka 2011-02-08 10:30:42 UTC
(In reply to comment #19)
> Still having the problem described in BZ 670089, even with
> system-config-printer-1.2.6-3.fc14. Trying to print "http://www.rhrk.uni-kl.de"
> on my lexmark network printer, nothing is printed, and the printer icon remains
> in the notification area for a lot of minutes, and the network is busy. By
> changing the driver from pxlmono to ljet4, I get rid of this problem.
Thanks for head up, but as you can see bug #661814 (which is 670089 duplicate of) is still in ASSIGNED state, so yes, we know that the problem is still there (probably foomatic package).

AFAIK *this* bug in system-config-printer would cause a different driver to be used than the one selected.

Comment 21 Fedora Update System 2011-03-15 21:55:29 UTC
system-config-printer-1.2.7-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.