This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 6676 - Non printing of timestamp if run through a named pipe
Non printing of timestamp if run through a named pipe
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: sysklogd (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-03 07:32 EST by matthew
Modified: 2014-03-16 22:11 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-05 15:47:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description matthew 1999-11-03 07:32:17 EST
I have a setup on my syslog such that it writes to a named
pipe on the disk, which is read by a PERL script, and
printed onto a tty. It would seem that some entries on this
don't get the timestamp or computer name printed (I use the
-r option to syslogd as well). It seems random as to whether
a given entry gets printed with the timestamp or not. If
this happens, then it would appear not to get logged to the
messages file.

In addition, I have had problems where log
events appear to be queued in /dev/log, and the system
suddenly prints them all when I restart syslog.
Comment 1 matthew 1999-11-09 13:09:59 EST
This seems to happen most under the logging done by the sshd on the
machine, with the 1.2.27-5i releases from ftp.replay.com . I
understand that these are unsupported, but I don't understand how the
messages are appearing without timestamps if they are coming through
the syslog mechanism, as they must be to appear on the display.
Comment 2 Bill Nottingham 2000-02-01 15:18:59 EST
Of course, if more log data than will fit in the pipe buffer
accumulates before the pipe is read, some of the data
won't be put in the pipe.

Aside from that, I can't reproduce this here. What does the
perl script look like?

Note You need to log in before you can comment on or make changes to this bug.