This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 66761 - RFE: some suggestions for ksconfig
RFE: some suggestions for ksconfig
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: ksconfig (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-15 16:05 EDT by Robert P. J. Day
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-11 11:39:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Robert P. J. Day 2002-06-15 16:05:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020607

Description of problem:
a few ideas for ksconfig

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.just run ksconfig
2.
3.
	

Additional info:

1. there is no option to select "autostep", while there is one to
   select "interactive" (even though i have no clue what autostep
   means -- the description says that it goes to the next screen
   for you -- this sounds like a normal ks install.)

2. several fields allow null values in the generated ks file --
   for example, the NFS server and directory.  another example
   is selecting static IP info, which allows null fields for the
   rest of that screen.  perhaps adding at least minimal field
   validation to a lot of the fields?

3. the "clearpart --drives" directive is not supported in 
   ksconfig, but that may be beyond the scope of ksconfig.
Comment 1 Tammy Fox 2002-07-03 15:10:42 EDT
katjz said that autostep should only be used for debugging - hence
I didn't add it to ksconfig. It is like a kickstart install, but
it pauses between screens to show you the values from the ks file.
It is like interactive, except it clicks Next for you after a few
seconds.
Comment 2 Brent Fox 2002-08-10 23:47:27 EDT
So, we're not going to implement #1.

I just implemented #2 and it should be in 2.3.2-9 when it gets rebuilt in a few
days.

We have supported #3 in the partitioning screen since the first versions of
ksconfig, if my memory serves me correctly.  However, I have slightly changed
the wording and widget layout in the most recent builds.

There are radio buttons that give you the following choices:
1) Remove all existing partitions
2) Remove existing Linux partitions
3) Preserve existing partitions


Resolving as Rawhide.  Thanks for your report.

Note You need to log in before you can comment on or make changes to this bug.