Bug 667684 - tsclient no longer supports passing client hostname to rdesktop
Summary: tsclient no longer supports passing client hostname to rdesktop
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: tsclient
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Søren Sandmann Pedersen
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: GSS_6_2_PROPOSED 697582 713024
TreeView+ depends on / blocked
 
Reported: 2011-01-06 13:50 UTC by J.H.M. Dassen (Ray)
Modified: 2018-11-14 15:46 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 16:48:47 UTC
Target Upstream Version:


Attachments (Terms of Use)
Proposed patch (68.15 KB, patch)
2011-01-06 13:50 UTC, J.H.M. Dassen (Ray)
no flags Details | Diff
Proposed patch (6.51 KB, patch)
2011-01-06 19:53 UTC, J.H.M. Dassen (Ray)
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1662 normal SHIPPED_LIVE tsclient bug fix update 2011-12-06 00:50:19 UTC

Description J.H.M. Dassen (Ray) 2011-01-06 13:50:05 UTC
Created attachment 472052 [details]
Proposed patch

Description of problem:
The tsclient version in RHEL6 has no apparent means of passing the client
hostname to rdesktop. This is a regression with respect to the tsclient that
came with RHEL5.

This becomes a problem for users that have to specify a client hostname to
avoid the bogus "No valid license available" message that the terminal
server spits out after many connects - specifying a bogus client hostname is
the only way to make further connections to the server.

Version-Release number of selected component (if applicable):
tsclient-2.0.2-6.el6

How reproducible:
100%

Steps to Reproduce:
1. Run "tsclient" in RHEL5.
2. Run "tsclient" in RHEL6, add a new connection of type "Windows Terminal
   Service Connection", look for an option to enter client hostname
   information.
  
Actual results:
1. Observe that the "Client Hostname" can be set in it for rdesktop client.
2. No option to enter client hostname information.

Expected results:
Option to enter client hostname information and have it passed to rdesktop.

Additional info:
Proposed patch (against upstream subversion's branches/tsclient-unstable
attached. The glade file part of this patch is fairly large due to changes
having been made through the glade-2 rather than directly. It can probably
be trimmed down for upstream submission.

Comment 1 J.H.M. Dassen (Ray) 2011-01-06 19:53:43 UTC
Created attachment 472122 [details]
Proposed patch

Revised patch - trimmed down the changes to the glade file.

I've verified that with this patch there are no additional glade warnings or Gtk messages beyond those that are generated with a build from unmodified upstream svn branch tsclient-unstable.

Comment 2 J.H.M. Dassen (Ray) 2011-04-14 07:34:17 UTC
Patch submitted upstream as <https://sourceforge.net/tracker/?func=detail&aid=3286397&group_id=192483&atid=941576>.

Comment 5 Søren Sandmann Pedersen 2011-08-06 05:12:23 UTC
Task info: http://brewweb.devel.redhat.com/brew/taskinfo?taskID=3538499

Comment 8 errata-xmlrpc 2011-12-06 16:48:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1662.html


Note You need to log in before you can comment on or make changes to this bug.