Bug 66769 - usb printer doesn't print
usb printer doesn't print
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: LPRng (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-15 20:36 EDT by Dr. Peter Boy
Modified: 2007-04-18 12:43 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-20 13:48:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
I'm seeing a similar problem w/usb HP 960c, clean Red Hat 7.3 install (15.24 KB, text/plain)
2002-06-18 20:57 EDT, Ken Giusti
no flags Details

  None (edit)
Description Dr. Peter Boy 2002-06-15 20:36:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
I'm asked to file the following problem to bugzilla in order to make it trackable.

I have an HP OfficeJet 85 connected to an USP port. The system seems to
recognize the printer, but it doesn't print.


hwbrowser is listing the HP OfficeJet as a printer. lsmod reports
usbcore and usb-uhci as well as printer. /proc/bus/usb/devices lists
the printer as well.

Using printconf-gui I configured the printer, but couldn't print the
test page (or any other print job), no matter which of the two printer
drivers I used. If I open KJob Viewer, the job ist listed for a short time,
saying it is beeing processed. But nothing happens on the printer.

The same is true, if  I switch to cups and configure the printer with the gui
tool. That tools reports, the print is offline (but it isn't).

All other printers (parallel and net) are working fine.


Couriously if I remove the usb printer module (rmmod printer) and start VMware,
I can print and scan from the Win guest OS.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Connect a HP OfficeJet to an USB port and configure it using
  printconf-gui
2.Try to print a test page
3.
	

Actual Results:  No page is printed

Additional info:
Comment 1 Ken Giusti 2002-06-18 20:57:55 EDT
Created attachment 61508 [details]
I'm seeing a similar problem w/usb HP 960c, clean Red Hat 7.3 install
Comment 2 Ken Giusti 2002-06-18 21:24:50 EDT
Just confirmed: re-cabled the printer to use its parallel port rather than its
USB port, reconfigured lpd via printconf-gui to use the parallel port. Printer
now works perfectly!

-K
Comment 3 mail 2002-12-28 08:08:38 EST
I have the same problem except I have been using the G85 for a while with
parallel interface. It has been working fine but I would like to use USB as it
should be faster for scanning. (I am using hpoj driver)
Comment 4 mail 2003-01-12 06:46:37 EST
This is actually not a bug. HP Officejet G55, G85, G95 needs HPOJ driver to
operate. It will not work if directly conected to your USB port. You can get the
driver and all the setup info at: http://hpoj.sourceforge.net/
I have been using G85 for scanning and printing for a while with parallel and
now with USB interface.
Comment 5 Tim Waugh 2003-01-20 13:47:40 EST
hpoj is now in rawhide.

Note You need to log in before you can comment on or make changes to this bug.