Bug 667737 - Zim crashes during startup while trying to convert notebooks
Zim crashes during startup while trying to convert notebooks
Status: CLOSED DUPLICATE of bug 653691
Product: Fedora
Classification: Fedora
Component: Zim (Show other bugs)
14
x86_64 Linux
high Severity medium
: ---
: ---
Assigned To: Chris Weyl
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-06 11:23 EST by David Kovalsky
Modified: 2014-03-31 19:46 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-06 12:03:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Kovalsky 2011-01-06 11:23:32 EST
Starting Zim in in Gnome asks me if I want to convert the notebooks to the new format. Clicking 'yes' converts a couple of them and then Zim dies. 

Here's verbose output from console:
kovinek:~                                                                                                                                                                                     
(0) $ /usr/bin/zim --verbose                                                                                                                                                                 
INFO: This is zim 0.49                                                                                                                                                                        
WARNING: This notebook needs to be upgraded to the latest data format                                                                                                                         
INFO: Opening default notebook                                                                                                                                                                
INFO: Starting UnixSocketDaemon                                                                                                                                                               
                                                                                                                                                                                              
kovinek:~                                                                                                                                                                                     
(0) $ WARNING: Could not find all icon sizes for the application icon                                                                                                                         
/usr/lib/python2.7/site-packages/zim/gui/__init__.py:574: GtkWarning: Inserting action group 'CalendarPlugin' into UI manager which already has a group with this name                        
                                                                                                                                                                                              
  self.uimanager.insert_action_group(handler.actiongroup, 0)                                                                                                                                  
WARNING: This notebook needs to be upgraded to the latest data format                                                                                                                         
INFO: Starting background index update                                                                                                                                                        
INFO: Open page: <FileStorePage: Private:Audi> (<HistoryRecord: Private:Audi>)                                                                                                                
INFO: Accelerator changed for <Actions>/CalendarPlugin/show_calendar                                                                                                                          
INFO: Index update done                                                                                                                                                                       
INFO: Notebook update started                                                                                                                                                                 
ERROR: Error in child main:
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/zim/daemon.py", line 541, in spawn
    self._main()
  File "/usr/lib/python2.7/site-packages/zim/daemon.py", line 585, in _main
    obj.main()
  File "/usr/lib/python2.7/site-packages/zim/gui/__init__.py", line 481, in main
    self.check_notebook_needs_upgrade()
  File "/usr/lib/python2.7/site-packages/zim/gui/__init__.py", line 784, in check_notebook_needs_upgrade
    self.notebook.upgrade_notebook(callback=lambda p: dialog.pulse(p.name))
  File "/usr/lib/python2.7/site-packages/zim/notebook.py", line 1317, in upgrade_notebook
    for page in self.walk():
  File "/usr/lib/python2.7/site-packages/zim/notebook.py", line 1282, in walk
    for p in self.index.walk(path):
  File "/usr/lib/python2.7/site-packages/zim/index.py", line 835, in _walk
    for grandchild in self._walk(child, childpath):
  File "/usr/lib/python2.7/site-packages/zim/index.py", line 827, in _walk
    cursor.execute('select * from pages where parent == ? order by lower(basename)', (path.id,))
InterfaceError: Error binding parameter 0 - probably unsupported type.
INFO: Last instance quit - exiting daemon
INFO: Stopped UnixSocketDaemon




Reproducible 100%. Zim-0.49-1.fc14.noarch
Comment 1 Robin Lee 2011-01-06 12:03:07 EST

*** This bug has been marked as a duplicate of bug 653691 ***

Note You need to log in before you can comment on or make changes to this bug.