Bug 667750 - /dev/hugepages should be created/mounted automatically
/dev/hugepages should be created/mounted automatically
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: udev (Show other bugs)
6.0
All Linux
high Severity low
: rc
: ---
Assigned To: Harald Hoyer
qe-baseos-daemons
: Triaged
Depends On: 541998
Blocks: F13VirtTarget
  Show dependency treegraph
 
Reported: 2011-01-06 12:01 EST by James M. Leddy
Modified: 2014-08-11 01:42 EDT (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
On previous releases /dev/hugepages could not be automatically be mounted even with an entry in /etc/fstab, because the directory was missing. This directory is now created in the start_udev script after /dev is mounted.
Story Points: ---
Clone Of: 541998
Environment:
Last Closed: 2011-05-19 07:50:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description James M. Leddy 2011-01-06 12:01:38 EST
+++ This bug was initially created as a clone of Bug #541998 +++

According to:

https://fedoraproject.org/wiki/Features/KVM_Huge_Page_Backed_Memory

...I should create /dev/hugepages and mounts hugetlbfs on it.  But this is a hack. There needs to be some automatic way to ensure that /dev/hugepages exists and is mounted; I shouldn't have to do it manually.

This is with libvirt-0.7.1-15.fc12.

--- Additional comment from ralston@pobox.com on 2010-02-10 15:23:26 EST ---

Created attachment 390107 [details]
patch to make /sbin/start_udev mkdir /dev/hugepages

The attached patch makes /sbin/start_udev mkdir /dev/hugepages, the same way it creates other subdirectories in /dev that are mount targets.

With this patch, the following line in /etc/fstab will do the trick:

hugetlbfs       /dev/hugepages  hugetlbfs defaults      0 0

--- Additional comment from ralston@pobox.com on 2010-02-10 15:25:39 EST ---

Reassigning to udev.

--- Additional comment from updates@fedoraproject.org on 2010-03-19 07:15:12 EDT ---

udev-145-16.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/udev-145-16.fc12

--- Additional comment from updates@fedoraproject.org on 2010-03-23 06:26:34 EDT ---

udev-151-7.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/udev-151-7.fc13

--- Additional comment from updates@fedoraproject.org on 2010-03-23 19:32:55 EDT ---

udev-151-7.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update udev'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/udev-151-7.fc13

--- Additional comment from updates@fedoraproject.org on 2010-03-23 19:39:30 EDT ---

udev-145-19.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update udev'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/udev-145-19.fc12

--- Additional comment from updates@fedoraproject.org on 2010-03-25 18:34:54 EDT ---

udev-145-19.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

--- Additional comment from updates@fedoraproject.org on 2010-03-25 18:39:12 EDT ---

udev-151-7.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

--- Additional comment from troels@arvin.dk on 2010-09-20 16:01:46 EDT ---

Could this fix be introduced in RHEL 5's udev, as well, please?
Comment 2 James M. Leddy 2011-01-06 13:55:11 EST
This should be in RHEL6, and arguably in every fedora release since it was introduced. I just confirmed that this isn't in f14
Comment 7 Harald Hoyer 2011-02-16 09:27:47 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
On previous releases /dev/hugepages could not be automatically be mounted even with an entry in /etc/fstab, because the directory was missing. This directory is now created in the start_udev script after /dev is mounted.
Comment 9 errata-xmlrpc 2011-05-19 07:50:43 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0525.html

Note You need to log in before you can comment on or make changes to this bug.