Bug 667818 - cobbler init script contains invalid syntax
cobbler init script contains invalid syntax
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: cobbler (Show other bugs)
rawhide
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: James C.
Fedora Extras Quality Assurance
:
Depends On: 667665
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-06 15:57 EST by Erik van Pienbroek
Modified: 2012-04-16 20:53 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 667665
Environment:
Last Closed: 2012-04-16 20:53:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Erik van Pienbroek 2011-01-06 15:57:23 EST
+++ This bug was initially created as a clone of Bug #667665 +++

On a fully updated rawhide environment (2011-01-06) I get a fatal systemd assertion error right after systemd gets started:

[/etc/rc.d/init.d/cobblerd:10] Failed to add dependency on network,.service, ignoring: Invalid argument
[/etc/rc.d/init.d/cobblerd:10] Failed to add dependency on xinetd,.service, ignoring: Invalid argument
Assertion 'unit_prefix_is_valid(prefix)' failed at src/unit-name.c:173, function unit_name_build(). Abort
Caught <ABRT>, core dump failed
Freezing execution.


Line 10 of /etc/rc.d/init.d/cobblerd contains this:
# Required-Start: network, xinetd, httpd

$ rpm -qa | grep -e systemd -e cobbler
cobbler-2.0.10-1.fc15.noarch
systemd-15-1.fc15.x86_64
cobbler-web-2.0.10-1.fc15.noarch
systemd-units-15-1.fc15.x86_64

--- Additional comment from notting@redhat.com on 2011-01-06 19:12:45 CET ---

Can you also file a bug against cobbler to fix the incorrect syntax?
Comment 1 Charles Butterfield 2011-10-09 16:35:46 EDT
I still see this in Fedora-15 with cobbler 2.0.11-2.fc15.  Any idea when it will be fixed?
Comment 2 Fedora Admin XMLRPC Client 2012-04-11 18:00:01 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 James C. 2012-04-16 20:53:30 EDT
I believe this issue has been fixed for a while, certainly in the 2.2.0 release at the latest. However if this is still an issue, please reopen via the github issue tracker for cobbler: https://github.com/cobbler/cobbler/issues

Note You need to log in before you can comment on or make changes to this bug.