Bug 66799 - Anaconda exits on incomplete isos - need better diagnostic dialog when error occurs
Summary: Anaconda exits on incomplete isos - need better diagnostic dialog when error ...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 8.0
Hardware: i386 Linux
low
low
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-06-17 02:27 UTC by Paul Iadonisi
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-05 02:38:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Paul Iadonisi 2002-06-17 02:27:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc3) Gecko/20020523

Description of problem:
I did an nfs/iso install.  But I did it after isos 1, 2, and 3 were done
downloading, but iso 4 was still downloading.  The installer kept complaining
that iso 4 wasn't a multiple of 2048 bytes.  But iso 4 (and 5) isn't needed
since it is only source code.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Copy isos 1, 2, and 3 into a directory
2.Do a partial copy of iso 4 (make sure it's not a multile of 2048 bytes) into
the same directory
3.Do an nfs iso install from this directory and witness as anaconda complains
and doesn't let the install proceed.
	

Actual Results:  Anaconda complains that iso 4 isn't a multiple of 2048 bytes
and prompts the user to click okay.  No option to continue is provided. 
Anaconda then exits.

Expected Results:  It would be nice if anaconda gave the user the option to
continue at his own risk.  Since there is no way to conclusively determine if an
iso is a source or binary iso without loopback mounting it (or hardcoding which
isos are binary), it's understandable if this can't be made smarter without
considerable effort.  Simply allowing installation to proceed is reasonable.

Additional info:

The workaround is easy -- just copy (or link) only the three complete isos to
another directory and install from there.

Comment 1 Michael Fulbright 2002-06-17 16:24:08 UTC
I can make the error message clearer to say that the installer expects only the
binary ISO images to be in a directory by themselves for the install to work.

Comment 2 Michael Fulbright 2002-11-01 17:07:04 UTC
Actually we're thinking of doing some changes so we identify a complete set of
isos w/o being confused by other isos.

Comment 3 Jeremy Katz 2004-10-05 02:38:43 UTC
We do better with this now.


Note You need to log in before you can comment on or make changes to this bug.