Bug 668025 - Host and nslookup doesn't use search directive in resolv.conf
Host and nslookup doesn't use search directive in resolv.conf
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
14
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-07 12:26 EST by Nuno Dias
Modified: 2013-04-30 19:48 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-18 09:12:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nuno Dias 2011-01-07 12:26:17 EST
Description of problem:
Host and nslookup doesn't use all the domains in search directive in resolv.conf

Version-Release number of selected component (if applicable):
bind-utils-9.7.2-5.P3.fc14.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Create a search directive in /etc/resolv.conf like this
search domain1.com domain2.com
2. 
3.
  
Actual results:
#host xpto
Host xpto not found: 3(NXDOMAIN)

#host xpto.domain2.com
xpto.domain2.com has address 192.168.0.1


Expected results:
#host xpto
xpto has address 192.168.0.1


Additional info:
Comment 1 Adam Tkac 2011-02-18 08:59:03 EST
I'm not able to reproduce this issue.

This is my /etc/resolv.conf:
$ cat /etc/resolv.conf 
# Generated by NetworkManager
search atkac.brq.redhat.com englab.brq.redhat.com brq.redhat.com
nameserver 10.34.24.36

There is DNS record called wiki.englab.brq.redhat.com and host utility resolves it correctly:

$ host wiki
wiki.englab.brq.redhat.com is an alias for wiki.lab.eng.brq.redhat.com.
wiki.lab.eng.brq.redhat.com has address 10.34.32.209

Can you run host with "-D -d" parameters and attach output, please? Thank you in advance.
Comment 2 Nuno Dias 2011-02-18 09:12:37 EST
Since the report of the problem, the problem has been solved (don't know how).

Note You need to log in before you can comment on or make changes to this bug.