Bug 668099 - lsof does not understand SCTP associations
Summary: lsof does not understand SCTP associations
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: lsof
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: 6.4
Assignee: Peter Schiffer
QA Contact: Iveta Wiedermann
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-01-07 21:53 UTC by Jeff Morriss
Modified: 2015-07-24 08:59 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Previously, lsof did not recognize Stream Control Transmission Protocol (SCTP) associations and consequently printed "can't identify protocol" at the end of the line describing a process using this type of association. With this update, support for SCTP has been added, and as a result, lsof correctly identifies SCTP associations in its output.
Clone Of:
Environment:
Last Closed: 2015-07-22 05:54:46 UTC


Attachments (Terms of Use)
sctp_demo.sh (982 bytes, application/x-shellscript)
2015-02-11 12:50 UTC, Peter Schiffer
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1246 normal SHIPPED_LIVE lsof bug fix update 2015-07-20 17:50:18 UTC

Description Jeff Morriss 2011-01-07 21:53:15 UTC
Description of problem:
lsof understands TCP and UDP connections, showing information about the port when run.

It does not do the same about SCTP associations, instead it says "can't identify protocol"

Version-Release number of selected component (if applicable):
lsof-4.78-3

How reproducible:
Every time

Steps to Reproduce:
1. Establish an SCTP association
2. Run lsof and look/grep for the process that has the association
3. Note that it says "can't identify protocol"
  
Actual results:
sctp_pitc  8024   morriss    3u     sock    0,5              83282 can't identify protocol


Expected results:
Something like:

sctp_pitc  8024   morriss    3u     IPv4  85073                SCTP myhost:54820->peer.example.com:10000 (ESTABLISHED)


Additional info:

Comment 1 RHEL Product and Program Management 2011-09-23 00:30:50 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Comment 2 Peter Schiffer 2012-03-06 17:10:43 UTC
I am moving this bug to the RHEL-6 as lsof probably won't be updated in RHEL-5 again.

Comment 5 RHEL Product and Program Management 2012-09-07 04:59:19 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.

Comment 6 RHEL Product and Program Management 2013-10-14 01:12:21 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.

Comment 7 Branislav Náter 2014-11-27 12:20:44 UTC
qa_ack+ for rhel-6.7

Comment 11 Peter Schiffer 2015-02-11 12:50:14 UTC
Created attachment 990447 [details]
sctp_demo.sh

Better sctp demo working on RHEL-6, RHEL-7 and Fedora

Comment 13 errata-xmlrpc 2015-07-22 05:54:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1246.html


Note You need to log in before you can comment on or make changes to this bug.