Bug 66813 - [gcc 3.1] i686 build failure using SRPM of kernel-2.4.9-34 (kdbmain.o)
[gcc 3.1] i686 build failure using SRPM of kernel-2.4.9-34 (kdbmain.o)
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-17 06:24 EDT by ipvcor
Modified: 2007-04-18 12:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-17 06:32:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ipvcor 2002-06-17 06:24:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; SunOS 5.8 sun4u)

Description of problem:
Couple of errors in this bug post - first, the easy one:

In the kernel-2.4.9-i386.config file from the SRPM, it contains two entries for
EXT3=m. If it's not in this config file, it's one of the other i386*config
files; i already fixed it and forgot the exact i386 config file. Doh! :)

i've built a bootstrapped gcc 3.1 and have been using it to recompile the kernel
SRPM. Both i386 and i586 were sucessful, but the i686 build barfed on kdbmain.o.
Output below:

/usr/src/redhat/BUILD/kernel-2.4.9/linux/include/asm/checksum.h:72:30: warning:
multi-line string literals are deprecated
/usr/src/redhat/BUILD/kernel-2.4.9/linux/include/asm/checksum.h:105:17: warning:
multi-line string literals are deprecated
/usr/src/redhat/BUILD/kernel-2.4.9/linux/include/asm/checksum.h:121:13: warning:
multi-line string literals are deprecated
/usr/src/redhat/BUILD/kernel-2.4.9/linux/include/asm/checksum.h:161:17: warning:
multi-line string literals are deprecated
kdbmain.c:71: conflicting types for `kdb_nextline'
/usr/src/redhat/BUILD/kernel-2.4.9/linux/include/linux/kdbprivate.h:70: previous
declaration of `kdb_nextline'
make[2]: *** [kdbmain.o] Error 1
make[1]: *** [first_rule] Error 2
make: *** [_dir_kdb] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.75128 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.75128 (%build)


Command used to build RPM (as root):
nohup rpm -ba --target i686 SPECS/kernel-2.4.spec &

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install kernel-2.4.9-34 SRPM (using gcc3.1)
2. Issue nohup rpm -ba --target i686 SPECS/kernel-2.4.spec &
3. Tail nohup.out and it'll fail on kdbmain.o
	

Actual Results:  i686 kernel build failed...

Expected Results:  Should have completed build of kernel...

Additional info:

[root@compilo root]# which gcc; gcc -v 
/usr/local/bin/gcc
Reading specs from /usr/local/lib/gcc-lib/i686-pc-linux-gnu/3.1/specs
Configured with: ./configure --enable-shared --enable-threads=posix
--disable-checking --with-system-zlib
Thread model: posix
gcc version 3.1


I have the nohup.out log if you want it...
Comment 1 Arjan van de Ven 2002-06-17 06:32:34 EDT
We know the 2.4.9 kernel isn't ready for gcc 3.1. It's not in several places ;(
For this specific case you can change

%define builddebug 1

to

%define builddebug 0

near the top of the spec file

Comment 2 ipvcor 2002-06-17 17:47:53 EDT
worked like a charm...

Note You need to log in before you can comment on or make changes to this bug.