Bug 66814 - Evolution does not start
Evolution does not start
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: evolution (Show other bugs)
7.3
i386 Linux
high Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-17 06:48 EDT by Christian Huettermann
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-17 15:43:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Christian Huettermann 2002-06-17 06:48:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020605

Description of problem:
Evolution does not start anymore (cannot initialize the Ximian Evolution shell:
Configuration Database not found).
The "usual" methods to resolve this (moving/removing $HOME/evolution and
$HOME/.gnome) do not work. Major strangeness going on. 
strace results etc available on request.



Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1.use KDE as your default desktop
2.start with GNOME
3.finish with ctrl-alt-backspace
4. log in with KDE/whatever again
5. start evolution
	

Actual Results:  cannot initialize the Ximian Evolution shell: Configuration
Database not found

[chuetter@konstanz chuetter]$ evolution

evolution-shell-WARNING **: Cannot access Bonobo/ConfigDatabase on wombat:
(IDL:OAF/GeneralError:1.0)


Additional info:
Comment 1 Jeremy Katz 2002-06-17 10:50:32 EDT
Have you upgraded mozilla?  Also, if you run `killev ; wombat` in a terminal,
what output do you get?
Comment 2 Christian Huettermann 2002-06-17 15:43:12 EDT
you got it. i've upgraded mozilla with the latest rpm from porkchop. the
dependency killed my evolution because it has not been able to find libraries in
/usr/lib/mozilla-1.0.0. wombat didnt want to start because of missing libs. 
adding this path to /etc/ld.so.conf fixed this for me.
You might want to check out an additional dependency or a proper path selection
for mozilla 'though.
Thanks for the hint.
Comment 3 Jeremy Katz 2002-06-17 16:01:21 EDT
Blizzard and I are already working on coordinating this in rawhide by getting
evolution linked with an rpath.

Note You need to log in before you can comment on or make changes to this bug.