Bug 668156 - blueman should not depend on polkit-gnome
blueman should not depend on polkit-gnome
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: blueman (Show other bugs)
14
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Juan Manuel Rodriguez
Fedora Extras Quality Assurance
:
Depends On:
Blocks: depchain 657006
  Show dependency treegraph
 
Reported: 2011-01-08 09:15 EST by Christoph Wickert
Modified: 2011-10-02 19:04 EDT (History)
3 users (show)

See Also:
Fixed In Version: blueman-1.21-10.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-24 23:48:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christoph Wickert 2011-01-08 09:15:09 EST
Description of problem:
gnome-session should not depend on polkit-gnome but rather use the virtual provides "PolicyKit-authentication-agent". We cannot and should not hardcode a certain authentication-agent, otherwise we trigger problems as in bug 657006.

Version-Release number of selected component (if applicable):
blueman-1.21-6.fc14.x86_64

Additional info:
This bug is not only about the bug 657006 but also because of the ongoing FESCo effort to get rid or dependency chain painpoints, see https://fedorahosted.org/fesco/ticket/345
Comment 1 Sebastian Krämer 2011-03-12 15:21:57 EST
Not sure if it fits this bug but blueman-dependency hell is mentioned in an upstream bug: https://bugs.edge.launchpad.net/blueman/+bug/491328
It's not really active though.
Comment 2 Elad Alfassa 2011-03-16 05:23:25 EDT
Also see bug 561019 comment 4.
Comment 3 Fedora Update System 2011-03-16 13:46:20 EDT
blueman-1.21-8.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/blueman-1.21-8.fc14
Comment 4 Fedora Update System 2011-03-16 13:57:42 EDT
blueman-1.21-9.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/blueman-1.21-9.fc15
Comment 5 Fedora Update System 2011-09-21 12:08:03 EDT
blueman-1.21-10.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/blueman-1.21-10.fc15
Comment 6 Fedora Update System 2011-09-24 23:48:28 EDT
blueman-1.21-8.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2011-10-02 19:04:11 EDT
blueman-1.21-10.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.