Bug 668158 - KeyError: 'wlan0'
Summary: KeyError: 'wlan0'
Keywords:
Status: CLOSED DUPLICATE of bug 642370
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Radek Vykydal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: anaconda_trace_hash:2038dca51f968e544...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-01-08 14:29 UTC by Slawomir Czarko
Modified: 2011-06-09 15:17 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-06-09 15:17:41 UTC


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (685.98 KB, text/plain)
2011-01-08 14:29 UTC, Slawomir Czarko
no flags Details

Description Slawomir Czarko 2011-01-08 14:29:51 UTC
The following was filed automatically by anaconda:
anaconda 14.22 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/pyanaconda/iw/network_gui.py", line 164, in selectInstallNetDeviceDialog
    desc = network.netdevices[dev].description
  File "/usr/lib/python2.7/site-packages/pyanaconda/gui.py", line 919, in enableNetwork
    nm_controlled_devices)
  File "/usr/lib/python2.7/site-packages/pyanaconda/yuminstall.py", line 1198, in doBackendSetup
    if not anaconda.intf.enableNetwork():
  File "/usr/lib/python2.7/site-packages/pyanaconda/backend.py", line 269, in doBackendSetup
    if anaconda.backend.doBackendSetup(anaconda) == DISPATCH_BACK:
  File "/usr/lib/python2.7/site-packages/pyanaconda/dispatch.py", line 212, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/python2.7/site-packages/pyanaconda/dispatch.py", line 131, in gotoNext
    self.moveStep()
  File "/usr/lib/python2.7/site-packages/pyanaconda/gui.py", line 1190, in nextClicked
    self.anaconda.dispatch.gotoNext()
KeyError: 'wlan0'

Comment 1 Slawomir Czarko 2011-01-08 14:29:57 UTC
Created attachment 472353 [details]
Attached traceback automatically from anaconda.

Comment 2 Radek Vykydal 2011-06-09 13:33:33 UTC
Thanks for the report and apologies for the delay, did you delete the wlan0 connection in Connection Editor? If so, this seems duplicate of bug #642370.

Comment 3 Slawomir Czarko 2011-06-09 14:47:43 UTC
(In reply to comment #2)
> Thanks for the report and apologies for the delay, did you delete the wlan0
> connection in Connection Editor? If so, this seems duplicate of bug #642370.

I don't remember right now since this has been few months ago but it's possible.

Comment 4 Radek Vykydal 2011-06-09 15:17:41 UTC
(In reply to comment #3)
 
> I don't remember right now since this has been few months ago but it's
> possible.

I see, I'm closing this bz as a duplicate of the #642370 which was fixed in Fedora 15. If you hit the issue again with Fedora 15 or newer, feel free to reopen the bug or file a new one.

*** This bug has been marked as a duplicate of bug 642370 ***


Note You need to log in before you can comment on or make changes to this bug.