Bug 66828 - libpcap error in pcap.h + bugzilla bug for posting bugs about libpcap
Summary: libpcap error in pcap.h + bugzilla bug for posting bugs about libpcap
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tcpdump   
(Show other bugs)
Version: 7.3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard: triage|leonardjo|closed|errata
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-06-17 14:34 UTC by Olivier Benghozi
Modified: 2007-04-18 16:43 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-08 10:20:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
spec file patch for include path to use /usr/include isntead of /usr/include/pcap (630 bytes, patch)
2002-07-01 00:41 UTC, Matthew Melvin
no flags Details | Diff

Description Olivier Benghozi 2002-06-17 14:34:03 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
1/ bugzilla doesn't allow to post bugs about libpcap (not in the list)
2/ <pcap/pcap.h> has a bad #include statement

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
#include <pcap/pcap.h>

gcc -lpcap bla.c


Additional info:

1/ Problem with bugzilla: There's no libpcap entry available in "RedHat Linux" 
selection to post bugs about it *** This is not a bug about libcap but about 
libpcap

2/ Bug in /usr/include/pcap/pcap.h (from libpcap package):
it says #include <net/bpf.h>
but there's no <net/bpf.h> (/usr/include/net/bpf.h).
In fact it should say #include <pcap/net/bpf.h>
because the file really is /usr/include/pcap/net/bpf.h

This prevents from using lib pcap in C programs.

Comment 1 Bernhard Rosenkraenzer 2002-06-17 14:40:05 UTC
# rpm -q --qf "%{SOURCERPM}" libpcap 
tcpdump-3.6.2-12.src.rpm 
 
-----> Not a bugzilla bug, libpcap is tcpdump

Comment 2 Harald Hoyer 2002-06-17 14:48:58 UTC
hmmm... temporal workaround -I /usr/include/pcap

Comment 3 Matthew Melvin 2002-07-01 00:41:56 UTC
Created attachment 63184 [details]
spec file patch for include path to use /usr/include isntead of /usr/include/pcap

Comment 4 Matthew Melvin 2002-07-01 00:42:19 UTC
Why is are the libpcap header files installed under /usr/include/pcap/ instead
of just /usr/include/ which seems to match expectations.  pcap.h itself seems to
expect this layout and there are plenty of messages on mailing lists saying "to
get this to compile on redhat do..." relating to this.  FWIW I use the attached
spec file patch to make things behave as expect (by me at least) on my systems...

Comment 5 Leonard den Ottolander 2004-04-08 10:20:41 UTC
Spec file patch was applied for tcpdump-3.6.3-17.7.3.2.

Closing ERRATA.



Note You need to log in before you can comment on or make changes to this bug.