Bug 668308 - [PATCH] telepathy-sofiasip crashes when receiving a call from user's own URI
Summary: [PATCH] telepathy-sofiasip crashes when receiving a call from user's own URI
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: telepathy-sofiasip
Version: 14
Hardware: i686
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Brian Pepple
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:f5d100938196ef49171a2b3fb94...
Keywords:
: 673761 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-01-10 00:28 UTC by Felix Möller
Modified: 2011-05-04 20:26 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2011-05-04 20:26:15 UTC


Attachments (Terms of Use)
File: backtrace (9.92 KB, text/plain)
2011-01-10 00:28 UTC, Felix Möller
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 33716 None None None Never

Description Felix Möller 2011-01-10 00:28:05 UTC
abrt version: 1.1.14
architecture: i686
Attached file: backtrace
cmdline: /usr/libexec/telepathy-sofiasip
component: telepathy-sofiasip
crash_function: tpsip_media_channel_receive_invite
executable: /usr/libexec/telepathy-sofiasip
kernel: 2.6.35.10-74.fc14.i686.PAE
package: telepathy-sofiasip-0.6.4-1.fc14
rating: 4
reason: Process /usr/libexec/telepathy-sofiasip was killed by signal 6 (SIGABRT)
release: Fedora release 14 (Laughlin)
How to reproduce: I have just tried to call my personal sip number hosted by sipgate.de. The signalling succeeded nevertheless...
time: 1294619148
uid: 500

Comment 1 Felix Möller 2011-01-10 00:28:09 UTC
Created attachment 472480 [details]
File: backtrace

Comment 2 Jesse Kahtava 2011-01-25 21:56:05 UTC
Package: telepathy-sofiasip-0.6.4-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Have empathy set up with sofia-sip
2. Call the SIP number
3. Empathy displays a message that the SIP account has disconnected and the crash notification is displayed

Comment 3 Felix Möller 2011-01-30 12:26:01 UTC
This still hapens with todays update to 0.6.5 I think.

See bug #673761.

Comment 4 Felix Möller 2011-01-30 12:33:24 UTC
Jesse how did you trigger this bug. I just did some debugging and it just seems to happen in case I call myself. This means from my sipgate account to my sipgate account.

I can without a crash let my cellphone ring.

Comment 5 Felix Möller 2011-01-31 18:55:38 UTC
I engaged with upstream today and sent them all kind of debugging traces. They were great to work with and created a patch, which I have successfully tested.

Please have a look at http://git.collabora.co.uk/?p=telepathy-sofiasip.git;a=commitdiff;h=df7937078faa3211a8eaae0342cd7bf297b4fc20

Comment 6 Fedora Update System 2011-01-31 23:44:49 UTC
telepathy-sofiasip-0.6.5-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/telepathy-sofiasip-0.6.5-2.fc14

Comment 7 Brian Pepple 2011-01-31 23:45:11 UTC
*** Bug 673761 has been marked as a duplicate of this bug. ***

Comment 8 Fedora Update System 2011-02-01 20:56:50 UTC
telepathy-sofiasip-0.6.5-2.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update telepathy-sofiasip'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/telepathy-sofiasip-0.6.5-2.fc14

Comment 9 Fedora Update System 2011-02-02 18:37:25 UTC
telepathy-sofiasip-0.6.6-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/telepathy-sofiasip-0.6.6-1.fc14

Comment 10 Fedora Update System 2011-02-13 08:57:20 UTC
telepathy-sofiasip-0.6.6-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Felix Möller 2011-05-04 19:58:00 UTC
I think this issue is fixed. Who is supposed to set it to RESOLVED FIXED?

Comment 12 Brian Pepple 2011-05-04 20:26:15 UTC
(In reply to comment #11)
> I think this issue is fixed. Who is supposed to set it to RESOLVED FIXED?

Bodhi should have set it when it was pushed to stable.


Note You need to log in before you can comment on or make changes to this bug.