Bug 668326 - mash config only allows one config section per file
Summary: mash config only allows one config section per file
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mash
Version: 14
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-01-10 04:00 UTC by Bradley
Modified: 2014-03-17 03:26 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-07-11 01:35:28 UTC


Attachments (Terms of Use)
Patch (591 bytes, patch)
2011-01-10 04:00 UTC, Bradley
no flags Details | Diff

Description Bradley 2011-01-10 04:00:48 UTC
Created attachment 472495 [details]
Patch

Description of problem:



Version-Release number of selected component (if applicable):

mash-0:0.5.20-1.fc14.noarch

How reproducible:

Always

Steps to Reproduce:
1. Create a file /etc/mash/test.mash:

[taga]

[tagb]

2. Run:

mash -o /tmp/tagb

Actual results:

ERROR: No configuration named 'tagb'!

Expected results:

configuration is found

Additional info:

This is because the MashDistroConfig is only set up per file, not per section, so any attributes set on the first section also apply to subsequent sections.

the mash config has:

                if not thisdistro.name:
                    thisdistro.name = sect

so they all end up with the name of the first section. Setting the |name| attribute is not a workaround; all that happens in the *last* section's name then gets used because the same thisdistro object is appended multiple times to config.distros.

Same bug is in the epel5 mash version

Comment 1 Fedora Update System 2012-06-22 20:18:22 UTC
mash-0.5.28-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2012-6209/mash-0.5.28-1.el6

Comment 2 Fedora Update System 2012-06-25 13:34:07 UTC
Package mash-0.5.28-1.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing mash-0.5.28-1.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2012-6209/mash-0.5.28-1.el6
then log in and leave karma (feedback).

Comment 3 Fedora Update System 2012-07-11 01:35:28 UTC
mash-0.5.28-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.