Bug 668391 - rakarrack-0.6.1 trouble using config from 0.5.8 stopping some effects working
Summary: rakarrack-0.6.1 trouble using config from 0.5.8 stopping some effects working
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rakarrack
Version: 14
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: David Timms
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 654786
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-01-10 11:45 UTC by David Timms
Modified: 2011-05-25 03:13 UTC (History)
3 users (show)

Fixed In Version: rakarrack-0.6.1-4.git47245c3.fc14
Doc Type: Enhancement
Doc Text:
Clone Of: 654786
Environment:
Last Closed: 2011-05-25 02:50:56 UTC
Type: ---


Attachments (Terms of Use)

Description David Timms 2011-01-10 11:45:53 UTC
+++ This bug was initially created as a clone of Bug #654786 +++

...snip

--- Additional comment from alukin@stu.cn.ua on 2010-12-28 12:26:05 EST ---

(In reply to comment #2)
> rakarrack-0.6.1-2.fc14 has been submitted as an update for Fedora 14.
> https://admin.fedoraproject.org/updates/rakarrack-0.6.1-2.fc14

After update from testing repo some effects do not work, producing terrible noise. It includes bass, rock amp and many others. Previous version 5.8 worked well.

--- Additional comment from alukin@stu.cn.ua on 2010-12-28 12:41:59 EST ---

Downgrading to 0.5.8 does not help, seems that some library upgraded. Switching of "Harmonizer" in Rackarrack GUI with "bass" effect withdraws noise but there's no bass.

...snip

--- Additional comment from alukin@stu.cn.ua on 2011-01-10 04:11:28 EST ---

Problem solved by changing forth and back resampling parameters in audio settings. May be some troblies with reading 0.5.8 config files?

Splitting issue into new bug.

Comment 1 David Timms 2011-01-10 11:49:02 UTC
Alex: I've created a new bug to track this issue.

If you create a new temporary user (in the appropriate audio group), and have the 0.6.1-2 version installed, are you able to reproduce this problem ?

Which preset are you using ? (I'm not clear on the steps you need to perform to see this problem).

Comment 2 Alex Lukin 2011-01-12 07:31:46 UTC
No, there's no problems with new user. Most distorted preset is Bass and all others that use pith shifting. My old setup with 0.5.8 used 2x resamplimg, I changed it to 4х and  back and tings returned to normal state.

Comment 3 David Timms 2011-05-11 11:08:40 UTC
Changing to on_qa, since there is a new build being done. The build will be available soon.

Comment 4 Fedora Update System 2011-05-11 13:24:22 UTC
rakarrack-0.6.1-4.git47245c3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/rakarrack-0.6.1-4.git47245c3.fc15

Comment 5 Fedora Update System 2011-05-11 13:25:35 UTC
rakarrack-0.6.1-4.git47245c3.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/rakarrack-0.6.1-4.git47245c3.fc14

Comment 6 Fedora Update System 2011-05-11 13:26:44 UTC
rakarrack-0.6.1-4.git47245c3.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/rakarrack-0.6.1-4.git47245c3.fc13

Comment 7 Fedora Update System 2011-05-13 23:06:41 UTC
Package rakarrack-0.6.1-4.git47245c3.fc13:
* should fix your issue,
* was pushed to the Fedora 13 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing rakarrack-0.6.1-4.git47245c3.fc13'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/rakarrack-0.6.1-4.git47245c3.fc13
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2011-05-25 02:50:36 UTC
rakarrack-0.6.1-4.git47245c3.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2011-05-25 02:55:30 UTC
rakarrack-0.6.1-4.git47245c3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2011-05-25 03:13:26 UTC
rakarrack-0.6.1-4.git47245c3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.