This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 668395 - Kickstart network command doesn't reconfigure active connection (unlike in rhel 5).
Kickstart network command doesn't reconfigure active connection (unlike in rh...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
Unspecified Unspecified
low Severity medium
: rc
: ---
Assigned To: Radek Vykydal
Release Test Team
:
: 666536 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-10 07:09 EST by Radek Vykydal
Modified: 2011-05-19 08:36 EDT (History)
2 users (show)

See Also:
Fixed In Version: anaconda-13.21.92-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-19 08:36:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Radek Vykydal 2011-01-10 07:09:08 EST
Description of problem:

In RHEL 5, first kickstart network command reactivated active network device with new configuration. In RHEL 6.0 it doesn't.

Version-Release number of selected component (if applicable):

RHEL 6.0

How reproducible:

always

Steps to Reproduce:
1. Install using kickstart from network, set network configuration on cmdline.
2. In kickstart have network command for the device activated/used to get kicktart with different configuration.
  
Actual results:

After kickstart is fetched the configuration from kickstart is not applied.
You can check with ifconfig on tty2 when available.

Expected results:

The configuration from kickstart file is applied and the device is reconfigured after fetching kickstart.

Additional info:
Comment 2 Radek Vykydal 2011-01-12 04:04:05 EST
*** Bug 666536 has been marked as a duplicate of this bug. ***
Comment 4 RHEL Product and Program Management 2011-01-19 10:30:24 EST
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux maintenance release. Product Management has 
requested further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed 
products. This request is not yet committed for inclusion in an Update release.
Comment 5 Radek Vykydal 2011-01-26 08:41:27 EST
This should be fixed in anaconda-13.21.92-1.
Comment 7 Alexander Todorov 2011-03-30 05:52:32 EDT
With anaconda-13.21.107-1.el6 the network configuration from ks.cfg was applied on top of the previous configuration passed on the command line. Moving to VERIFIED.
Comment 8 errata-xmlrpc 2011-05-19 08:36:49 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0530.html

Note You need to log in before you can comment on or make changes to this bug.