Bug 66851 - Misleading error if HTTP install server address is wrong.
Misleading error if HTTP install server address is wrong.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i386 Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-17 15:08 EDT by Sam Varshavchik
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-06 19:59:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sam Varshavchik 2002-06-17 15:08:39 EDT
I tried to do an HTTP install from pcmcia.img, and I entered the wrong server IP
address.  The error message that came up on the next screen was "Unable to find
/RedHat/Base/netstg1.img on the server", without mentioning the IP address.  It
took me a little while to figure out that I entered the wrong IP server IP
address; the error message led me on a wild goose chase, looking at the apache
configuration on the server, etc.

Since I entered IP addresses, error recovery code should distinguish between two
error condition: unable to contact the server; and receiving a 404 from the server.
Comment 1 Michael Fulbright 2002-06-20 11:48:19 EDT
Assigning to an engineer.
Comment 2 Jeremy Katz 2003-01-03 01:23:07 EST
Made the error message give the full URL that's unable to be retrieved so that 
it's more obvious
Comment 3 Mike McLean 2003-01-06 19:59:23 EST
fix verified in -re0106.0

Note You need to log in before you can comment on or make changes to this bug.