Bug 668547 - Error dialog causes traceback and lock up
Summary: Error dialog causes traceback and lock up
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.1
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: rc
: ---
Assignee: Adrian Likins
QA Contact: J.C. Molet
URL:
Whiteboard:
Depends On:
Blocks: Entitlement-Beta
TreeView+ depends on / blocked
 
Reported: 2011-01-10 19:04 UTC by J.C. Molet
Modified: 2011-05-19 13:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-19 13:38:44 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2011:0611 normal SHIPPED_LIVE new package: subscription-manager 2011-05-18 17:56:21 UTC

Description J.C. Molet 2011-01-10 19:04:50 UTC
Description of problem:
When subscribing to a subscription that you are already subscribed to it throws an error.  This is the expected behavior, except that the error dialog itself seems to throw a traceback.  This sometimes causes subscription-manager-gui to lock up completely.

Version-Release number of selected component (if applicable):
subscription-manager-firstboot-0.93.10-1.git.4.433f1bd.el6.x86_64
subscription-manager-gnome-0.93.10-1.git.4.433f1bd.el6.x86_64
subscription-manager-0.93.10-1.git.4.433f1bd.el6.x86_64


How reproducible:
Traceback happens always.
The lock up happens randomly and cannot be consistently reproduced.

Steps to Reproduce:
1.  Install rhsm-gui and all required deps.
2.  Register rhsm
3.  Subscribe to a subscription that has at least 2 available subscriptions
4.  Toggle the search filters so you can see the subscription you just subscribed to again.
5.  Try to subscribe to that subscription again.
6.  Hit ok on the error pop up.
  
Actual results:
The dialog throws this traceback:

Traceback (most recent call last):
  File "/usr/share/rhsm/gui/messageWindow.py", line 64, in _on_response_event
    self.emit('response', rc)
TypeError: object at 0x1f14c30 of type ErrorDialog is not initialized
Traceback (most recent call last):
  File "/usr/share/rhsm/gui/messageWindow.py", line 64, in _on_response_event
    self.emit('response', rc)
TypeError: object at 0x1f14c30 of type ErrorDialog is not initialized
Traceback (most recent call last):
  File "/usr/share/rhsm/gui/messageWindow.py", line 64, in _on_response_event
    self.emit('response', rc)
TypeError: object at 0x1f14c30 of type ErrorDialog is not initialized
Traceback (most recent call last):
  File "/usr/share/rhsm/gui/messageWindow.py", line 64, in _on_response_event
    self.emit('response', rc)
TypeError: object at 0x1f14c30 of type ErrorDialog is not initialized

Sometimes when you hit OK it locks up the program.

Expected results:
There error dialog shows and closes normally.

Comment 1 Adrian Likins 2011-01-12 16:44:54 UTC
This seems to be working now. I think the commit:


commit 5923ded32b3f4da3ce34af3db977ec79113538cd
Author: Devan Goodwin <dgoodwin@redhat.com>
Date:   Fri Jan 7 15:06:30 2011 -0400

    668006: Error handling fixes.
    
    Removed the translated string from python-rhsm (which shouldn't have
    translations required) in favor of an actual NetworkException, which we
    can catch here and then display the translated message.
    
    Includes some general error handling cleanup.


May have fixed this issue as well.

Comment 2 J.C. Molet 2011-01-20 15:25:29 UTC
python-rhsm-0.94.15-1.git.0.b738ea1.el6.noarch
subscription-manager-0.93.13-1.git.4.769efa1.el6.x86_64
subscription-manager-firstboot-0.93.13-1.git.4.769efa1.el6.x86_64
subscription-manager-gnome-0.93.13-1.git.4.769efa1.el6.x86_64


fixed as tested in ^

Comment 3 errata-xmlrpc 2011-05-19 13:38:44 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2011-0611.html


Note You need to log in before you can comment on or make changes to this bug.