Bug 668581 - "Why is compliance important?" runs outside the window
Summary: "Why is compliance important?" runs outside the window
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.1
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: rc
: ---
Assignee: Bryan Kearney
QA Contact: J.C. Molet
URL:
Whiteboard:
: 669456 (view as bug list)
Depends On:
Blocks: Entitlement-Beta
TreeView+ depends on / blocked
 
Reported: 2011-01-10 20:15 UTC by J.C. Molet
Modified: 2013-01-10 10:48 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-19 13:38:46 UTC
Target Upstream Version:


Attachments (Terms of Use)
why comply (441.53 KB, image/png)
2011-01-10 20:34 UTC, J.C. Molet
no flags Details
Paul's mockup. (141.98 KB, application/pdf)
2011-01-13 20:49 UTC, Bryan Kearney
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2011:0611 normal SHIPPED_LIVE new package: subscription-manager 2011-05-18 17:56:21 UTC

Description J.C. Molet 2011-01-10 20:15:05 UTC
Description of problem:
Upon startup of subscription-manager-gui, the "Why is compliance important?" line runs outside of its container.

Version-Release number of selected component (if applicable):
subscription-manager-firstboot-0.93.10-1.git.4.433f1bd.el6.x86_64
subscription-manager-gnome-0.93.10-1.git.4.433f1bd.el6.x86_64
subscription-manager-0.93.10-1.git.4.433f1bd.el6.x86_64

Steps to Reproduce:
1. Install subscription manager gui and all of its deps.
2. Run the program
  
Actual results:
The "why is compliance important" line runs off the screen and hides the 'i' icon (see screenshot).  The window must be resized to be seen correctly.

Expected results:
Upon initial startup, everything is displayed fully using the default window size.

Additional info:
This could easily be fixed by changing the default size of the window.  This is not my preferred method as the gui interface is rather large already, and would be pretty rough to run on a low resolution screen.  My suggestions would be either the icon could be moved, made to be printed on two lines, or it could be removed entirely and the blue 'i' icon could be placed next to the text right below the compliance check or X mark.

Comment 1 J.C. Molet 2011-01-10 20:34:19 UTC
Created attachment 472680 [details]
why comply

Attached with my elite gimp skillz.

Comment 2 Bryan Kearney 2011-01-13 20:48:06 UTC
I a hijacking this bug.The latest UXD mockup removes that text. So, it would resolve the bug.

The fix for this bug is to make the ui match the attched mockup including:

1) Shrink the size of the compliance icon
2) remove the offending "Why important" text
3) Move the system name into the facts, under system (See UUID). Remove it from the front page.
4) Make the toolbox into a 2x2 grid with a wrapper.

Comment 3 Bryan Kearney 2011-01-13 20:49:19 UTC
Created attachment 473423 [details]
Paul's mockup.

Comment 4 Bryan Kearney 2011-01-14 13:17:53 UTC
*** Bug 669456 has been marked as a duplicate of this bug. ***

Comment 6 J.C. Molet 2011-01-20 15:28:38 UTC
python-rhsm-0.94.15-1.git.0.b738ea1.el6.noarch
subscription-manager-0.93.13-1.git.4.769efa1.el6.x86_64
subscription-manager-firstboot-0.93.13-1.git.4.769efa1.el6.x86_64
subscription-manager-gnome-0.93.13-1.git.4.769efa1.el6.x86_64

New layout design as tested in the above version gets rid of this item altogether.

Comment 7 errata-xmlrpc 2011-05-19 13:38:46 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2011-0611.html


Note You need to log in before you can comment on or make changes to this bug.