Bug 66859 - RH 7.3 installer does not recognize SCSI partitions made during RH 7.0 install
RH 7.3 installer does not recognize SCSI partitions made during RH 7.0 install
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-17 16:04 EDT by Jim Turner
Modified: 2007-04-18 12:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-14 12:44:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim Turner 2002-06-17 16:04:16 EDT
Description of Problem: See Service Request Ticket #207448. Apparent problem with RH 7.3 installer not recognizing partitions on sdb previously 
partitioned during RH 7.0 install.  Computer is a Dell with factory installed SSCI controller and sda - all hardware info is included in Ticket. If you 
find 
a cause for this problem I would like to hear. As indicated in ticket I have at least temporarily solved this problem at my end.


Version-Release number of selected component (if applicable):


How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 Jeremy Katz 2002-06-19 19:44:00 EDT
Development does not have access to support's tracking systems -- could you
please provide the information on your problem here?
Comment 2 Jim Turner 2002-06-20 09:27:18 EDT
Here are my exchanges with tech support (in reverse order):

18-JUN-2002 14:31:55 EST
                                 Notify Customer with e-mail notification.
                                                                                      Gian Paulo 
                                                                                                          
   Technician Response
                                 Dear Sir,

                                 It is unfortunate that you had to upgrade to 7.3 using the hard way of
                                 transerring backed up files.  But it is also good that your system is now up
                                 and running on 7.3

                                 However, related to the previous issues, it seems like we have a bug on our
                                 hands.  The problem with your SCSI hard disk is generally related to 7.3.  

                                 Please send a bug report to Bugzilla.  This will send a report to Red Hat's
                                 development and update team.  They are eager to find bugs in 7.3 in order to
                                 squash them as soon as possible.  Your issue can help.  Here's the link for
                                 bugzilla:

                                   http://bugzilla.redhat.com/bugzilla/easy_enter_bug.cgi

                                 If you have other installation concerns, please create a new ticket.

                                 Regards,
                                 Paulo Ng

    
   17-JUN-2002 15:54:14 EST
                                 Request Updated
                                                                                  Turner, R. James
                                                                                                          
   Customer Request
                                 I was never given a choise of what harddisk to use, when I tried a 7.3 update I
                                 just got a message that there were no linux partitions on either drive (see 
                                 my previous note). After I wrote to you last I tried a workstation installation
                                 using fdisk and found that it could see all the partitions on sdb (whereas 
                                 disk druid could not - see my previous note) but of course this did not help
                                 with the update. In any case over the weekend I did a clean install of 7.3
                                 using 
                                 disk druid. It seems to have worked fine so my problems are at least
                                 temporarily over (saving and restoring what was in my 7.0 installation was less
                                 work 
                                 than getting the 7.3 upgrade to work). One thing I did notice - on my old
                         installation I had a 4GB FAT32 partition on sdb. When I tried to set up a
                                 partition 
                                 of this size during the 7.3 installation I was not allowed to do this - the
                                 program told me that a 2048 MB fatv partition was the maximum size. But I don't

                                 see how this could have caused my previous problems. I included the makes and
                                 models of my hardware in a previous note to you.

    
   17-JUN-2002 09:45:08 EST
                                 Notify Customer with e-mail notification.
                                                                                      Gian Paulo 
                                                                                                          
   Technician Response
                                 Dear Sir,

                                 Just to make sure, when you ran the upgrade installation, did you get a prompt
                                 to select which SCSI harddisk you want to work on?  Make sure to select sdb.

                                 If that did nothing, then we would need to do an unconventional method to
                                 troubleshoot.  Please remove your first harddisk and use diskdruid.  Check if
                                 Disk Druid can detect your Linux hard disk.  Whatever the outcome, make sure
                                 you do not edit anything on the partition so that your 7.0 files will not be
                                 destroyed.

                                 If this works, then there may be issues with your SCSI controller with 7.3. 
                                 Can you please give us the specifications of your SCSI controller as well as
                                 your SCSI harddisks?  I will need the make and model of all of them.  

                                 What might have happened is that your SCSI controller and disks could have been
                                 listed in our Hardware Compatibility List as "Community Knowledge" and
                                 therefore worked with a workaround.  Maybe know, your hardware won't work with
                                 7.3.  This, however is a "what if scenario" which we cannot overlook.

                                 There is also the possibility of a bug.  In this case, you may want to send a
                                 bug report to Bugzilla, which is Red Hat's development team.  Sending a bug
                                 report will address this issue directly to them.  Here's the link for bugzilla:

                                   http://bugzilla.redhat.com/bugzilla/easy_enter_bug.cgi

                                 Eitherway, please give your hardware specifications to us.

     We will await your reply.
                                   
                                 Regards,
                                 Paulo Ng

    
   14-JUN-2002 10:11:29 EST
                                 Request Updated
                                                                                  Turner, R. James
                                                                                                          
   Customer Request
                                 I have tried the things you suggested but the problem remains - on a
                                 Workstation install from RH 7.3 I always get the message "The                  
                                        
                                 partition table on device sdb was unreadable." Specifically:
                                 - During the installation boot prompt I entered  "text noprobe" and selected 
                                 aic7xxx or  aic7xxx_old from the list (there was no aic7xxx_mod), the 
                                 problem remained.
                                 - I created a driver disk and proceeded as you suggested but got the same
                                 result
                                 Additionally:
                                 - as I previously indicated the RH 7.0 installation disk has no problem seeing
                                 the partitions on sdb
                                 - when I used the driver disk created above (using RH 7.3 disk 1) with the RH
                                 7.0 installation disk entering "linux text dd" at the boot prompt there was no 

                                 problem, so the driver disk seems to be fine.
                                 - both the RH 7.0 and 7.3 installation disks automatically load the driver
                                 aicxxx

                                 So it appears that the problem is not with the driver.

                                 There is an additional peculiarity of my system that I am wondering about. On
                                 sda there are actually 3 partitions, a 2000M (approx) NTFS partition, a 
                                 7000M NTFS partition and a small (8M) unassigned partition - I'm not sure where
                                 the small partition came from. The RH 7.0 installation does not 
                                 comment on the small partition but does display it. But the RH 7.3 installation
                                 tells me about the partition (after I choose Disk Druid) and gives me the 
                                 choice "Ignore" or "Cancel". When I choose "Ignore" nothing happens so I have
                                 to choose "Cancel". Then I get the message that the partition table on 
                                 device sdb is unreadable. Is it possible that choosing "Cancel" causes the
                                 program to abort looking at the second drive. If so assigning this small 
                                 partition should solve the problem - how do I do this?

    
   13-JUN-2002 02:58:58 EST
                                 Notify Customer with e-mail notification.
                                                                                      Gian Paulo 
                                                                                                          
   Technician Response
                                 Dear Sir,

                                 Before we proceed, I must inform you that Installation Support only provides
                                 limited support for upgrade installations.  We cannot provide support for
                                 restoring damaged files after an upgrade.  So it is essential that you backup
                                 your important files and configurations before an upgrade so that you can still
                                 recover your files if there is a problem with the upgrade.  Sometimes there are
                                 issues after an upgrade from 7.0 to 7.3.

                                 Now, let's proceed to your query.  During the installation boot prompt, please
                                 enter this parameter:

                                   text noprobe

                                   Then select from the SCSI list:

                                     aic7xxx

                                     or

                                     aic7xxx_mod

                                     NOTE: the noprobe option will allow you to choose from the SCSI list.



                                 An alternate way is to let the installation detect the SCSI disk properly by
                                 using a driver disk.  You can do this by creating a disk with the drvblock.img
                                 (Supplemental Block Device Drivers) which can be found in your Red Hat
                                 Installation Disk 1.  

                                 To create the driver disk, run this command on a console with the Installation
                                 disk and a formatted floppy disk inside their respective drives:

                                   dd if=/mnt/cdrom/images/drvblock.img of=/dev/fd0

                                 Now proceed with the installation by booting off the Red Hat Installation CD. 
                                 On the installation boot prompt, use these parameters:

                                   linux text dd

                                     or

                                   linux text expert

                                 When you are asked to insert a driver disk, insert the created driver disk and
                                 the proper drivers for you SCSI disk will be chosen.


                                 This should enable your SCSI partitions to be seen.  If you have other
                                 installation concerns, please create a new ticket.

                                 Regards,
                                 Paulo Ng

    
   12-JUN-2002 09:31:54 EST
                                 Request Updated
                                                                                  Turner, R. James
                                                                                                          
   Customer Request
                                 The problem is not that the hard drives are not being detected. Win2000 sees
                                 both drives as does the RH 7.0 installation disk. The RH 7.0 installation 
                                 disk can also see all of the partitions on both drives. The RH 7.3 installation
                                 disk also sees both drives and can see the partitions on sda - however, it 
                                 doesn't seem to be able to read the partition table on sdb. My hardware is as
                                 follows:

                                 Dell 410 Workstation with factory installed (integrated) HD controller (Adaptec
                                 7890 Ultrawide2/wide SCSI controller), factory installed SCSI HD 
                                 (Quantum Viking II 9.1 WLS SCSI) and user installed SCSI HD (Seagate ST318436LW
                                 SCSI) - these are sda and sdb, respectively, there are no other 
                                 HD's in the computer.

    
   11-JUN-2002 01:59:06 EST
                                 Notify Customer with e-mail notification.
                                                                                      Gian Paulo 
                                                                                                          
   Technician Response
                                 Dear Sir,

                                 It seems like your SCSI hard drives are not being detected.  Please send us the
                                 make and model of your SCSI hard disks and controller so that we can simulate
                                 this case further.

                                 If you have other concerns about installation, feel free to create a new
                                 ticket.

                                 Regards,
                                 Paulo Ng

    
   10-JUN-2002 10:38:15 EST
                                 Problem Description
                                                                                  Turner, R. James
                                                                                                          
   Customer Request
                                 I have a Dell 410 Workstation with 2 SCSI drives. I have Win2000 on the first
                                 drive (sda) and RH 7.0 on the second (sdb). I boot Win2000 from the HD 
                                 and RH 7.0 from a floppy. I am trying to upgrade to RH 7.3. When I run the
                                 installation program (booting from the CD) and attempt to upgrade I get the 
                                 message: "You don't have any Linux partition. You can't upgrade the system".
                                 When I try a complete Workstation installation I get the message "The 
                                 partition table on device sdb was unreadable. To create new partitions it must
                                 be initiallized causing loss of ALL DATA on the drive". But if I use my old 
                                 RH 7.0 installation CD and choose "Upgrade" it sees the partitions on sdb with
                                 no problem. I would prefer not to do a clean install with RH 7.3 - can I get 
                                 around this problem?

Comment 3 Michael Fulbright 2002-06-20 11:56:49 EDT
Thanks!

Assigning to an engineer.
Comment 4 Jeremy Katz 2002-06-21 16:44:33 EDT
If you run parted on /dev/sdb, what output do you get?
Comment 5 Jim Turner 2002-06-27 17:11:53 EDT
Sorry I am new to Linux and haven't been able to figure out how to use parted (I found it in the sbin directory but can't seem to run it). Please let me 
know how its done. Note however, that my immediate problem has been solved - I did a clean install of RH 7.3 - so will parted give you useful 
information?
Comment 6 Jeremy Katz 2002-07-01 17:11:26 EDT
It should still be useful.  
Run '/sbin/parted /dev/sdb' as root and then when you get the parted prompt,
type 'print'.

Also, what scsi controllers are in use on your system?
Comment 7 Jim Turner 2002-07-05 10:36:16 EDT
Output from parted:

Disk geometry for /dev/sdb:  0.000-17522.054 magabytes
Disk label type: mdos
Minor    Start            End           Type          Filesystem      Flags
1            0.031        62.753        primary            ext3           boot
2          62.754    2110.100       primary           FAT
3       2110.100   2368.959       primary          linux-swap
4      2368.960     17516.184   extended                             lba
5      2368.991     17516.184     logical             ext3


I wasn't able to find a way to copy this into a file so I hope I have transcribed the numbers from the screen correctly. When parted first ran there was 
also a warning message about there being a FAT partition on the drive and something about how if my BIOS supported LAT(?) I should do 
something - I ignored this but if you need the details I can get them.

My hard drive controller:  factory installed (integrated) HD controller Adaptec 7890 Ultrawide2/wide SCSI controller

There is also a second SCSI controller that controls a RW CD drive, I think it is a 7880 Adaptec not 2wide - sorry I didn't write this down but I can get 
it also if you need it.
Comment 8 Jim Turner 2002-08-14 12:44:42 EDT
Has there been any progress on this?
Comment 9 Jeremy Katz 2002-09-20 15:41:59 EDT
Unfortunately, I can't really tell anything that might have been the cause of
the problem.  And without the hardware at hand, it's hard to say.  The fact that
you could just workaround it by reinstalling points to something being a little
bit off in the install you were trying to upgrade.

Note You need to log in before you can comment on or make changes to this bug.